Difference between revisions of "Epgsync-plugin"

From VDR Wiki
Jump to: navigation, search
(Problems: new release)
 
Line 1: Line 1:
 
==Description==
 
==Description==
<!-- [[Image:(missing)-plugin.jpg|thumb|Screenshot]] -->
+
'''Author:''' Frank Schmirler
Imports the [[EPG]] of an other VDR using the [[Svdrp]] protocol. For connecting the [[svdrpservice-plugin]] is used which has to be installed along with epgsync.
+
  
The actual import runs as a background thread. You can start the thread from the main menu or automatically whenever the plugin is started.
+
Imports the [[EPG]] of another VDR using the Svdrp protocol. For connecting the svdrpservice-plugin is used which has to be installed along with epgsync.
<!-- ==Hardware requirements== -->
+
The actual import runs as background thread. The thread can be started from main menu and/or automatically whenever the plugin is started.  
  
==Software requirements==
+
===Status===
[[svdrpservice-plugin]] >= 0.0.2
+
Last Update 06/2013
  
==Installation==
+
==Software Requirements==
See [[plugin installation]]
+
* [[svdrpservice-plugin]] >= 0.0.2
  
==Problems==
+
==Current Version(en)==
===epgsync-plugin 0.0.1===
+
[http://vdr.schmirler.de/svdrpservice/vdr-svdrpservice-1.0.0.tgz 1.0.0]
Everyone who uses 0.0.1 should update. With 0.0.1 you may encounter the following problems:
+
* Crash when an unexpected error occurs while syncing (connection broken, buffer full, ...)
+
* Impact of epgsync due to thread priority (like e.g. dropped frames)
+
+
===Buffer size===
+
Large EPG entries might exceed the internal buffer size. The log will show something like
+
svdrpservice: line too long in reply from ...
+
Increase the buffer size to e.g. 32k by editing [[svdrpservice-plugin]]'s connection.h:
+
#define BUFFER_SIZE KILOBYTE(32)
+
  
 
==Links==
 
==Links==
{|
+
# [http://vdr.schmirler.de Plugins Homepage]
| [1]
+
| http://vdr.schmirler.de/
+
| Plugin homepage
+
|}
+
  
 
[[Category:Plugins]]
 
[[Category:Plugins]]
 +
[[Category:EPG_and_Co]]
 +
[[Category:Svdrp-tools]]
  
{{i18n|Epgsync-plugin}}
+
{{i18n|epgsync-plugin}}

Latest revision as of 18:29, 8 December 2013

Description

Author: Frank Schmirler

Imports the EPG of another VDR using the Svdrp protocol. For connecting the svdrpservice-plugin is used which has to be installed along with epgsync. The actual import runs as background thread. The thread can be started from main menu and/or automatically whenever the plugin is started.

Status

Last Update 06/2013

Software Requirements

Current Version(en)

1.0.0

Links

  1. Plugins Homepage