Graphtft-plugin

From VDR Wiki
Revision as of 12:43, 6 October 2004 by Monroe (Talk | contribs)

Jump to: navigation, search

Description

Hardware requirements

  • TFT display

Software requirements

  • imlib2
  • ffmpeg

Installation

First the prerequisites imlib2

cd $SOURCEDIR
tar xvzf imlib2-<VERSION>.tar.gz
cd imlib2-<VERSION>
./configure --prefix=/usr/local
make
make install
ldconfig
cd -

and ffmpeg

tar xvzf ffmpeg-<VERSION>.tar.gz
ln -s ffmpeg-<VERSION> ffmpeg
cd ffmpeg
./configure --prefix=/usr/local --enable-shared
make
make install
ldconfig

For the plugin to work you need the Vera truetype font (others will possibly work too)

mkdir -p /etc/vdr/plugins/graphTFT/fonts
cp /path/to/Vera.ttf /etc/vdr/plugins

If you don't know where to find Vera.ttf try the command

locate Vera.ttf

The skins goes to /etc/vdr/plugins/graphTFT/themes

mkdir -p /etc/vdr/plugins/graphTFT/themes
tar jxvf standard.tar.bz2 -C /etc/vdr/plugins/graphTFT/themes

For the rest see plugin installation.

Parameter

Parameter (short) Parameter (long) Description
-d DEV --device=DEV sets the device i.e.: /dev/fb0 or for VDR-Dev.: vdr/1

Problems

Links

[1] http://www-math.uni-paderborn.de/~tegeler/vdr/graphtft Plugin homepage
[2] http://www.enlightenment.org/pages/imlib2.html imlib2 homepage
[3] http://ffmpeg.sourceforge.net ffmpeg homepage
[4] http://www.haile.ch/vdr Skins/Themes
[5] http://xpix.dieserver.de/downloads Skins/Themes