Talk:AVerMedia AVerTV Hybrid+FM Cardbus (E506R)

From LinuxTVWiki
Jump to: navigation, search

Faq & Discussion

Cardbus iomem

root@zeppo v4l]# cat /proc/iomem
00000000-0009f7ff : System RAM
0009f800-0009ffff : reserved
000a0000-000bffff : Video RAM area
000c0000-000cefff : Video ROM
000d8000-000d8fff : Adapter ROM
000f0000-000fffff : System ROM
00100000-37e9ffff : System RAM
  00200000-004f30bd : Kernel code
  004f30be-00715007 : Kernel data
37ea0000-37eabfff : ACPI Tables
37eac000-37efffff : ACPI Non-volatile Storage
37f00000-3fffffff : reserved
50000000-51ffffff : PCI Bus #06
  50000000-51ffffff : PCI CardBus #07
52000000-53ffffff : PCI CardBus #07
  52000000-520007ff : 0000:07:00.0
    52000000-520007ff : saa7133[0]
b0000000-b0000fff : 0000:00:13.0
  b0000000-b0000fff : ohci_hcd
b0001000-b0001fff : 0000:00:13.1
  b0001000-b0001fff : ohci_hcd
b0002000-b0002fff : 0000:00:13.2
  b0002000-b0002fff : ehci_hcd
b0003000-b00033ff : 0000:00:14.0
b0003400-b00034ff : 0000:00:14.5
  b0003400-b00034ff : ATI IXP AC97
b0003800-b00038ff : 0000:00:14.6
  b0003800-b00038ff : ATI IXP MC97
b0100000-b01fffff : PCI Bus #01
  b0100000-b010ffff : 0000:01:05.0
  b0120000-b013ffff : 0000:01:05.0
b0200000-b02fffff : PCI Bus #06
  b0200000-b0203fff : 0000:06:04.2
  b0204000-b0205fff : 0000:06:02.0
  b0206000-b0207fff : 0000:06:04.3
    b0206000-b0207fff : tifm_7xx1
  b0208000-b0208fff : 0000:06:04.0
    b0208000-b0208fff : yenta_socket
  b0209000-b02097ff : 0000:06:04.2
    b0209000-b02097ff : ohci1394
  b0209800-b02098ff : 0000:06:04.4
    b0209800-b02098ff : sdhci:slot2
  b0209c00-b0209cff : 0000:06:04.4
    b0209c00-b0209cff : sdhci:slot1
  b020a000-b020a0ff : 0000:06:04.4
    b020a000-b020a0ff : sdhci:slot0
  b020a400-b020a4ff : 0000:06:06.0
    b020a400-b020a4ff : 8139too
c0000000-cfffffff : PCI Bus #01
  c0000000-cfffffff : 0000:01:05.0
e0000000-efffffff : reserved
fec00000-fec0ffff : reserved
fee00000-fee00fff : reserved
fff80000-ffffffff : reserved

Sound

What is the problem with sound? I have video but I don't have sound. Is this principal problem or nobody is busy with it?

Satarsa


I don't have that device for testing, I just added support for loading a firmware which is supposed to work with another device. Audio has always been a problem with all devices but I got all my devices work properly.

Markus


I will be in Germany (big probability) in April in Berlin and in May in Hamburg. I can bring it :-)

Also, I will be in France (Grenoble) from 7 March to 19 March.

If I'd be able to help, it'd be very cool! :-)

Satarsa


I'm in Dresden, about 1 1/2 hours away from Berlin by train, it's definitelly worth to visit Dresden :)

Markus


Ok, let's discuss it later when I will have got a visa. :-)

Question: why is not saa7134-alsa compiled? The compiler goes around saa7134-alsa diligently, even it is turned on in the kernel.

Satarsa


Hi, Markus!

I will be in Berlin from 30.04 to 22.05. I think we should discuss it by email. My email is dyadkin_74rtdgsad_gmail.com where _74rtdgsad_ = @ ;)

Satarsa


DVB-T

Hello,

Thank you for this helpfull article. Unfortunatelly, I can not use the DVB-T part. Is this related to firmware or I miss something during installation? I downloaded firmwares as described on http://linuxtv.org/v4lwiki/index.php/Em2880#Installation.

uname -a
Linux bilbo 2.6.19.2-jn #1 SMP Sat Feb 3 19:08:40 CET 2007 i686 GNU/Linux

These are outputs, based on different firmwares:

firmware.tgz

[  120.576000] saa7130/34: v4l2 driver version 0.2.14 loaded
[  120.600000] saa7134 ALSA driver for DMA sound loaded
[  120.600000] saa7134 ALSA: no saa7134 cards found
[  127.344000] pccard: CardBus card inserted into slot 1
[  127.344000] PCI: Enabling device 0000:06:00.0 (0000 -> 0002)
[  127.344000] ACPI: PCI Interrupt 0000:06:00.0[A] -> GSI 18 (level, low) -> IRQ 17
[  127.344000] saa7133[0]: found at 0000:06:00.0, rev: 209, irq: 17, latency: 0, mmio: 0x26000000
[  127.344000] PCI: Setting latency timer of device 0000:06:00.0 to 64
[  127.344000] saa7133[0]: subsystem: 1461:f436, board: AVerMedia Cardbus TV/Radio (E506R) [card=104,autodetected]
[  127.344000] saa7133[0]: board init: gpio is 220000
[  127.464000] tuner 0-0061: chip found @ 0xc2 (saa7133[0])
[  127.468000] Tuner: setting up tuner core extension for: Xceive 3028 Tuner
[  127.468000] ERROR TUNER TYPE NOT SUPPORTED (-854524908)
[  127.504000] saa7133[0]: i2c eeprom 00: 61 14 36 f4 00 00 00 00 00 00 00 00 00 00 00 00
[  127.504000] saa7133[0]: i2c eeprom 10: 00 ff e2 0e ff 20 ff ff ff ff ff ff ff ff ff ff
[  127.504000] saa7133[0]: i2c eeprom 20: 01 40 01 02 02 01 01 03 08 ff 00 ff ff ff ff ff
[  127.504000] saa7133[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[  127.504000] saa7133[0]: i2c eeprom 40: ff 65 00 ff c2 1e ff ff ff ff ff ff ff ff ff ff
[  127.504000] saa7133[0]: i2c eeprom 50: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[  127.504000] saa7133[0]: i2c eeprom 60: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[  127.504000] saa7133[0]: i2c eeprom 70: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[  127.504000] Loading base firmware: xc3028_init0.i2c.fw
[  127.560000] XC3028: NO GPIO CALLBACK FUNCTION PROVIDED - SWITCHING MODES WON'T WORK (GPIO FW ARG: 0)!
[  136.056000] Loading default analogue TV settings: xc3028_BG_PAL_A2_A.i2c.fw
[  136.252000] saa7133[0]: registered device video0 [v4l2]
[  136.252000] saa7133[0]: registered device vbi0
[  136.252000] saa7133[0]: registered device radio0
[  136.252000] saa7133[0]/alsa: saa7133[0] at 0x26000000 irq 17 registered as card -1
[  174.000000] em28xx v4l2 driver version 0.0.1 loaded
[  174.000000] usbcore: registered new interface driver em28xx

firmware_v2.tgz

[  182.344000] pccard: CardBus card inserted into slot 1
[  182.344000] PCI: Enabling device 0000:06:00.0 (0000 -> 0002)
[  182.344000] ACPI: PCI Interrupt 0000:06:00.0[A] -> GSI 18 (level, low) -> IRQ 17
[  182.344000] saa7133[0]: found at 0000:06:00.0, rev: 209, irq: 17, latency: 0, mmio: 0x26000000
[  182.344000] PCI: Setting latency timer of device 0000:06:00.0 to 64
[  182.344000] saa7133[0]: subsystem: 1461:f436, board: AVerMedia Cardbus TV/Radio (E506R) [card=104,autodetected]
[  182.344000] saa7133[0]: board init: gpio is 220000
[  182.464000] tuner 0-0061: chip found @ 0xc2 (saa7133[0])
[  182.472000] Tuner: setting up tuner core extension for: Xceive 3028 Tuner
[  182.472000] ERROR TUNER TYPE NOT SUPPORTED (-855051244)
[  182.508000] saa7133[0]: i2c eeprom 00: 61 14 36 f4 00 00 00 00 00 00 00 00 00 00 00 00
[  182.508000] saa7133[0]: i2c eeprom 10: 00 ff e2 0e ff 20 ff ff ff ff ff ff ff ff ff ff
[  182.508000] saa7133[0]: i2c eeprom 20: 01 40 01 02 02 01 01 03 08 ff 00 ff ff ff ff ff
[  182.508000] saa7133[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[  182.508000] saa7133[0]: i2c eeprom 40: ff 65 00 ff c2 1e ff ff ff ff ff ff ff ff ff ff
[  182.508000] saa7133[0]: i2c eeprom 50: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[  182.508000] saa7133[0]: i2c eeprom 60: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[  182.508000] saa7133[0]: i2c eeprom 70: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[  182.508000] Loading base firmware: xc3028_init0.i2c.fw
[  190.948000] Loading default analogue TV settings: xc3028_BG_PAL_A2_A.i2c.fw
[  191.164000] saa7133[0]: registered device video0 [v4l2]
[  191.164000] saa7133[0]: registered device vbi0
[  191.164000] saa7133[0]: registered device radio0
[  191.164000] saa7133[0]/alsa: saa7133[0] at 0x26000000 irq 17 registered as card -1
[  206.964000] em28xx v4l2 driver version 0.0.1 loaded
[  206.964000] usbcore: registered new interface driver em28xx

firmware_v3.tgz

[  177.748000] pccard: CardBus card inserted into slot 1
[  177.748000] PCI: Enabling device 0000:06:00.0 (0000 -> 0002)
[  177.748000] ACPI: PCI Interrupt 0000:06:00.0[A] -> GSI 18 (level, low) -> IRQ 17
[  177.748000] saa7133[0]: found at 0000:06:00.0, rev: 209, irq: 17, latency: 0, mmio: 0x26000000
[  177.748000] PCI: Setting latency timer of device 0000:06:00.0 to 64
[  177.748000] saa7133[0]: subsystem: 1461:f436, board: AVerMedia Cardbus TV/Radio (E506R) [card=104,autodetected]
[  177.748000] saa7133[0]: board init: gpio is 220000
[  177.868000] tuner 0-0061: chip found @ 0xc2 (saa7133[0])
[  177.872000] Tuner: setting up tuner core extension for: Xceive 3028 Tuner
[  177.872000] ERROR TUNER TYPE NOT SUPPORTED (-723287020)
[  177.908000] saa7133[0]: i2c eeprom 00: 61 14 36 f4 00 00 00 00 00 00 00 00 00 00 00 00
[  177.908000] saa7133[0]: i2c eeprom 10: 00 ff e2 0e ff 20 ff ff ff ff ff ff ff ff ff ff
[  177.908000] saa7133[0]: i2c eeprom 20: 01 40 01 02 02 01 01 03 08 ff 00 ff ff ff ff ff
[  177.908000] saa7133[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[  177.908000] saa7133[0]: i2c eeprom 40: ff 65 00 ff c2 1e ff ff ff ff ff ff ff ff ff ff
[  177.908000] saa7133[0]: i2c eeprom 50: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[  177.908000] saa7133[0]: i2c eeprom 60: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[  177.908000] saa7133[0]: i2c eeprom 70: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[  177.908000] Loading base firmware: xc3028_init0.i2c.fw
[  178.000000] XC3028: NO GPIO CALLBACK FUNCTION PROVIDED - SWITCHING MODES WON'T WORK (GPIO FW ARG: 0)!
[  186.376000] Loading default analogue TV settings: xc3028_BG_PAL_A2_A.i2c.fw
[  186.588000] saa7133[0]: registered device video0 [v4l2]
[  186.588000] saa7133[0]: registered device vbi0
[  186.588000] saa7133[0]: registered device radio0
[  186.588000] saa7133[0]/alsa: saa7133[0] at 0x26000000 irq 17 registered as card -1
[  203.868000] em28xx v4l2 driver version 0.0.1 loaded
[  203.868000] usbcore: registered new interface driver em28xx

firmware_v4.tgz

[  208.340000] pccard: CardBus card inserted into slot 1
[  208.340000] PCI: Enabling device 0000:06:00.0 (0000 -> 0002)
[  208.340000] ACPI: PCI Interrupt 0000:06:00.0[A] -> GSI 18 (level, low) -> IRQ 17
[  208.340000] saa7133[0]: found at 0000:06:00.0, rev: 209, irq: 17, latency: 0, mmio: 0x26000000
[  208.340000] PCI: Setting latency timer of device 0000:06:00.0 to 64
[  208.340000] saa7133[0]: subsystem: 1461:f436, board: AVerMedia Cardbus TV/Radio (E506R) [card=104,autodetected]
[  208.340000] saa7133[0]: board init: gpio is 220000
[  208.460000] tuner 0-0061: chip found @ 0xc2 (saa7133[0])
[  208.464000] Tuner: setting up tuner core extension for: Xceive 3028 Tuner
[  208.464000] ERROR TUNER TYPE NOT SUPPORTED (-777678828)
[  208.500000] saa7133[0]: i2c eeprom 00: 61 14 36 f4 00 00 00 00 00 00 00 00 00 00 00 00
[  208.500000] saa7133[0]: i2c eeprom 10: 00 ff e2 0e ff 20 ff ff ff ff ff ff ff ff ff ff
[  208.500000] saa7133[0]: i2c eeprom 20: 01 40 01 02 02 01 01 03 08 ff 00 ff ff ff ff ff
[  208.500000] saa7133[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[  208.500000] saa7133[0]: i2c eeprom 40: ff 65 00 ff c2 1e ff ff ff ff ff ff ff ff ff ff
[  208.500000] saa7133[0]: i2c eeprom 50: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[  208.500000] saa7133[0]: i2c eeprom 60: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[  208.500000] saa7133[0]: i2c eeprom 70: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[  208.500000] Loading base firmware: xc3028_init0.i2c.fw
[  216.900000] Loading default analogue TV settings: xc3028_BG_PAL_A2_A.i2c.fw
[  217.112000] saa7133[0]: registered device video0 [v4l2]
[  217.112000] saa7133[0]: registered device vbi0
[  217.112000] saa7133[0]: registered device radio0
[  217.112000] saa7133[0]/alsa: saa7133[0] at 0x26000000 irq 17 registered as card -1

Well I'd need to have a sample of that device by myself.

Markus


Is a chance, that you will visit Prague in Czech Republic? What are other options? Shall I send it to you?

--Navratil 16:51, 7 February 2007 (CET)


in summer maybe, definitelly not now :-) but you can also send it to me for a while yes.

Markus



Could we discuss details offline? My email is Jiri Navratil.

--Navratil 23:34, 8 February 2007 (CET)


sure.

Markus