Difference between revisions of "Libv4l Upside Down Webcams"

From LinuxTVWiki
Jump to: navigation, search
(Ubuntu Precise)
 
Line 21: Line 21:
  
 
Because Skype is a 32bit binary one needs to install the 32bit libv4l-0 package:
 
Because Skype is a 32bit binary one needs to install the 32bit libv4l-0 package:
 +
dpkg --add-architecture i386
 +
apt-get update
 
  apt-get install libv4l-0:i386
 
  apt-get install libv4l-0:i386
  
 
Edit  /usr/share/applications/skype.desktop and replace the Exec line with:
 
Edit  /usr/share/applications/skype.desktop and replace the Exec line with:
 
  Exec=sh -c 'LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so skype'
 
  Exec=sh -c 'LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so skype'

Latest revision as of 22:12, 1 October 2012

This page is supposed to give guidance if the webcam image is displayed upside down.

Upgrading libv4l package to latest stable

The upside down table included in libv4l gets updated with new laptop / webcam combinations that also suffer the upside down webcam problem. Although it's possible to compile and instal a newer libv4l by hand, installing an updated distribution package is preferable.

A good hint if it's worth to upgrade libv4l is to run the qv4l2 program from v4l-utils. If the image there is correct, there is no need to upgrade. If it's upside down, upgrading is a good idea.

Ubuntu

Add the stable libv4l PPA and upgrade packages:

apt-add-repository ppa:libv4l/stable
apt-get update
apt-get upgrade

Fix upside down webcams in Skype

To fix the upside down camera problem for most Skype users it's necessary to preload the v4l1convert library. This can be either done from the command line or more convenient by editing the skype.desktop file.

Ubuntu Precise

Because Skype is a 32bit binary one needs to install the 32bit libv4l-0 package:

dpkg --add-architecture i386
apt-get update
apt-get install libv4l-0:i386

Edit /usr/share/applications/skype.desktop and replace the Exec line with:

Exec=sh -c 'LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so skype'