Talk:Pinnacle PCTV HD Pro Stick (800e)

From LinuxTVWiki
Revision as of 15:53, 9 January 2009 by Jj71 (Talk | contribs)

Jump to: navigation, search

So when I do:

modprobe em28xx device_mode=1 i2c_scan=1

I get:

...
Dec  3 22:29:59 cheren kernel: [17179957.448000] em28xx #0: found i2c device @ 0x1c [???]
Dec  3 22:29:59 cheren kernel: [17179957.472000] em28xx #0: found i2c device @ 0xa0 [eeprom]
Dec  3 22:29:59 cheren kernel: [17179957.476000] em28xx #0: found i2c device @ 0xc2 [tuner (analog)]
...

What is at 0x1c? Would this be the DVB demodulator? In analog mode I get:

...
Dec  3 22:37:30 cheren kernel: [17180407.836000] em28xx #0: found i2c device @ 0xa0 [eeprom]
Dec  3 22:37:30 cheren kernel: [17180407.840000] em28xx #0: found i2c device @ 0xb8 [tvp5150a]
Dec  3 22:37:30 cheren kernel: [17180407.840000] em28xx #0: found i2c device @ 0xc2 [tuner (analog)]
...

--Emeitner 05:44, 4 December 2006 (CET)


yes it's the ATSC demod in your case. Only one chip can be visible at a time so first we focussed on NTSC, next step os ATSC.

Markus


Notes on audio

Audio has a clicking sound every 256ms(I measured it) with varying amplitude. I just did this to get a sample:

sox -r 48000 -w -c 2 -t ossdsp /dev/dsp1 -t wav /tmp/test.wav

Sample here: [[1]]

--Emeitner 02:26, 6 December 2006 (CET)



this is a known issue I already had it work properly a longer time ago but since then many things changed and I'm not able to test it till christmas.

Markus

Odd connector??

I recently got one of these "Pinnacle PCTV HD Pro Stick"'s and I was wondering- is the connector on the side {that connects to s-video, stereo audio, and composite video} even a standard connector? If so, what's the pinout? [I know at least one of you peeps is a hardware hacker, surely...] My mom has a digital camera that uses an almost identical, if not exactly identical connector to connect to USB with one cable, but to connect to stereo audio and composite video with another cable, and I was wondering if these cables/devices would work together...?

Help installing

Can anybody help me out with my installation? I've tried both the latest ~mrec on mcentral.de mercurial version and the standard v4l-dvb newest mercurial version and I'm not really sure what's going on. I have V4L and DVB turned off in my kernel config and right now I have the mrec. I've been following http://www.2nrds.com/digital-tv-in-linux-with-em28xx-devices but when I run modprobe em28xx, I get the following:

WARNING: Error inserting tveeprom (/lib/modules/2.6.24-gentoo-r8/kernel/drivers/media/video/tveeprom.ko): Invalid module format
WARNING: Error inserting v4l1_compat (/lib/modules/2.6.24-gentoo-r8/kernel/drivers/media/video/v4l1-compat.ko): Invalid module format
WARNING: Error inserting v4l2_common (/lib/modules/2.6.24-gentoo-r8/kernel/drivers/media/video/v4l2-common.ko): Invalid module format
WARNING: Error inserting videodev (/lib/modules/2.6.24-gentoo-r8/kernel/drivers/media/video/videodev.ko): Invalid module format
WARNING: Error inserting ir_common (/lib/modules/2.6.24-gentoo-r8/kernel/drivers/media/common/ir-common.ko): Invalid module format
WARNING: Error inserting compat_ioctl32 (/lib/modules/2.6.24-gentoo-r8/kernel/drivers/media/video/compat_ioctl32.ko): Invalid module format
FATAL: Error inserting em28xx (/lib/modules/2.6.24-gentoo-r8/kernel/drivers/media/video/em28xx/em28xx.ko): Unknown symbol in module, or unknown parameter (see dmesg)

The relevant part of dmesg:

tveeprom: exports duplicate symbol tveeprom_read (owned by kernel)
v4l1_compat: exports duplicate symbol v4l_compat_translate_ioctl (owned by kernel)
v4l2_common: exports duplicate symbol v4l2_chip_match_host (owned by kernel)
videodev: exports duplicate symbol video_device_release (owned by kernel)
ir_common: exports duplicate symbol ir_rc5_timer_keyup (owned by kernel)
compat_ioctl32: exports duplicate symbol v4l_compat_ioctl32 (owned by kernel)
em28xx: Unknown symbol ir_codes_pinnacle2
em28xx: Unknown symbol ir_codes_em_pinnacle2_usb
em28xx: Unknown symbol ir_codes_em_gadmei_usb
em28xx: Unknown symbol ir_codes_em_terratec2
em28xx: Unknown symbol ir_codes_em_pinnacle_usb

Am I missing something for my kernel config?

PS I also just tried the v4l-dvb-experimental branch as suggested in various places and I get the same problems. Also tried reenabling v4l and dvb in my kernel as modules and then doing make install with the mercurial branch and that didn't change anything.

Any ideas?

Thanks,

--Eitan1989 23:43, 16 June 2008 (CEST)

Edit: Problem solved, I seem to have forgotten to install my new kernel after I compiled it. Sorry!

Firmware problems in Fedora 10

I have previously successfully installed the firmware under Acer Linpus following the directions. But in Fedora 10 there doesn't seem to be a "linux/Documentation/video4linux" folder or an "extract_xc3028.pl" script. So I'm rather stuck.

Any ideas?