Difference between revisions of "TechnoTrend TT-budget S2-3200"

From LinuxTVWiki
Jump to: navigation, search
(information and instruction for locking problem, removal of instructions to use hg (deprecated) to install v4l-dvb)
 
(7 intermediate revisions by 3 users not shown)
Line 1: Line 1:
 
A [[DVB-S2]] [[DVB-S2 PCI Cards|PCI card]] from [[TechnoTrend]].
 
A [[DVB-S2]] [[DVB-S2 PCI Cards|PCI card]] from [[TechnoTrend]].
  
This card '''supported''' (but not working properly) in the stock kernel as of version 2.6.29 [http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=9e0dc6606a4f26a70cede6bf181cbff21f4c5477 commit].
+
This card '''supported''' (but not working properly)(???) in the stock kernel as of version 2.6.29 [http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=9e0dc6606a4f26a70cede6bf181cbff21f4c5477 commit].
  
 
==Overview==
 
==Overview==
Line 23: Line 23:
  
 
==Drivers==
 
==Drivers==
 +
 +
This card works like a charm and out of the box like TT-connect S2 3600 USB in Ubuntu.
 +
No firmware installation needed.
  
 
This card '''supported''' (but not working properly) in the stock kernel as of version 2.6.29 [http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=9e0dc6606a4f26a70cede6bf181cbff21f4c5477 commit] so you should start off by trying the standard 2.6.29 (or later) kernel  
 
This card '''supported''' (but not working properly) in the stock kernel as of version 2.6.29 [http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=9e0dc6606a4f26a70cede6bf181cbff21f4c5477 commit] so you should start off by trying the standard 2.6.29 (or later) kernel  
Line 31: Line 34:
 
===Card only rarely locks onto any transponder===
 
===Card only rarely locks onto any transponder===
  
This is a known issue, and there is a patch available for it. First you have to compile v4l-dvb, instructions to do this can be found at [[How_to_Obtain,_Build_and_Install_V4L-DVB_Device_Drivers]]. Next, you need to apply this patch: [https://patchwork.kernel.org/patch/244201/ Patchwork [v2] V4L/DVB: faster DVB-S lock for mantis cards using stb0899 demod].
+
This is a known issue, and there is a patch available for it. First you have to get v4l-dvb source, instructions to do this can be found at [[How_to_Obtain,_Build_and_Install_V4L-DVB_Device_Drivers]]. Next, you need to apply this patch: [https://linuxtv.org/patch/4573/ Patchwork V4L/DVB: faster DVB-S lock for mantis cards using stb0899 demod]
 +
 
  
 
I welcome anyone to improve my instructions as they are messy (no time to figure out how to do this properly), but this will work:
 
I welcome anyone to improve my instructions as they are messy (no time to figure out how to do this properly), but this will work:
  
1. Go to your media_build/linux directory.
+
* Go to your media_build/linux directory.
2. Make a new textfile called "stb0899.patch". Copy/paste the contents of the patch into it and save the file.
+
* Make a new textfile called "stb0899.patch". Copy/paste the contents of the patch into it and save the file.
3. Change a/ and b/ everywhere in the file to ./ so the paths point to your local files.
+
* Change a/ and b/ everywhere in the file to ./ so the paths point to your local files.
4. Go to the commandline, cd to your media_build/linux directory.
+
* Go to the commandline, cd to your media_build/linux directory.
5. Run "patch -p0 < stb0899.patch". If you get messages about failed hunks, godspeed.
+
* Run "patch -p0 < stb0899.patch". If you get messages about failed hunks, godspeed.
6. Compile and install v4l-dvb. Reboot/reload modules.
+
* Compile and install v4l-dvb. Reboot/reload modules.
  
Now, DVB-S transponders will lock reliably. I still see DVB-S2 transponders sometimes not locking properly in kaffeine and I will investigate whether this problem is kaffeine-related or if "scan" has the same problem. For now, this patch upgrades the S2-3200 from being a paperweight (it's too light for that really, I suggest using it as a bookmark) to a completely capable DVB-S tuner that, with some persuasion, can even be used for DVB-S2.
+
Now, DVB-S transponders will lock reliably. I still see DVB-S2 transponders sometimes not locking properly in kaffeine and I will investigate whether this problem is kaffeine-related or if "scan" has the same problem. I've seen enormous data corruption occuring when tuning a DVB-S2 transponder, like there is a thunderstorm, but restarting kaffeine generally solves it. For now, this patch upgrades the S2-3200 from being a paperweight (it's too light for that really, I suggest using it as a bookmark) to a completely capable DVB-S tuner that, with some persuasion, can even be used for DVB-S2.
  
 
===Status/problems===
 
===Status/problems===

Latest revision as of 21:08, 30 June 2013

A DVB-S2 PCI card from TechnoTrend.

This card supported (but not working properly)(???) in the stock kernel as of version 2.6.29 commit.

Overview

This card is apparently also available/rebranded as the TechniSat SkyStar HD.

Components Used

It also supports an add-on CI slot using the budget_ci module.

Identification

Type

lspci -v

You should get lots of output, including a paragraph something like this:

04:01.0 Multimedia controller: Philips Semiconductors SAA7146 (rev 01)
 Subsystem: Technotrend Systemtechnik GmbH S2-3200
 Flags: bus master, medium devsel, latency 64, IRQ 16
 Memory at febffc00 (32-bit, non-prefetchable) [size=512]

Drivers

This card works like a charm and out of the box like TT-connect S2 3600 USB in Ubuntu. No firmware installation needed.

This card supported (but not working properly) in the stock kernel as of version 2.6.29 commit so you should start off by trying the standard 2.6.29 (or later) kernel and making sure that the appropriate kernel modules are loaded.

Only start looking at experimental drivers described below if you need more recent changes or fixes.

Card only rarely locks onto any transponder

This is a known issue, and there is a patch available for it. First you have to get v4l-dvb source, instructions to do this can be found at How_to_Obtain,_Build_and_Install_V4L-DVB_Device_Drivers. Next, you need to apply this patch: Patchwork V4L/DVB: faster DVB-S lock for mantis cards using stb0899 demod


I welcome anyone to improve my instructions as they are messy (no time to figure out how to do this properly), but this will work:

  • Go to your media_build/linux directory.
  • Make a new textfile called "stb0899.patch". Copy/paste the contents of the patch into it and save the file.
  • Change a/ and b/ everywhere in the file to ./ so the paths point to your local files.
  • Go to the commandline, cd to your media_build/linux directory.
  • Run "patch -p0 < stb0899.patch". If you get messages about failed hunks, godspeed.
  • Compile and install v4l-dvb. Reboot/reload modules.

Now, DVB-S transponders will lock reliably. I still see DVB-S2 transponders sometimes not locking properly in kaffeine and I will investigate whether this problem is kaffeine-related or if "scan" has the same problem. I've seen enormous data corruption occuring when tuning a DVB-S2 transponder, like there is a thunderstorm, but restarting kaffeine generally solves it. For now, this patch upgrades the S2-3200 from being a paperweight (it's too light for that really, I suggest using it as a bookmark) to a completely capable DVB-S tuner that, with some persuasion, can even be used for DVB-S2.

Status/problems

A problem with locking high symbol rate channels (DVB-S2 30000 3/4 transponders) has been reported a number of times: http://linuxtv.org/pipermail/linux-dvb/2009-January/031673.html, http://linuxtv.org/pipermail/linux-dvb/2009-February/031779.html . it is solved, buffer was too small. Unfortunately there's a tuning bug, but if you use 29998 instead of 30000 everything is working fine now.


Such transponders can be found at Thor 0.8W and Hispasat 30.0W.

A way to use the similar (but USB) TechnoTrend TT-connect S2-3650 CI to help fix problem has been suggested here: http://www.spinics.net/lists/linux-media/msg01169.html .

Another way is to use 29999.999MHz for symbol rate. ( Successfully test with Eutelsat W2 / EuroBird 16E, Madagascar beam with OrangeTV)

Do you have the TT3200 or TT3650 ? Can you help debug the driver?

v4l-dvb/S2API driver

Since kernel 2.6.28, DVB-S2 support has been implemented in the Linux kernel by means of a new API, version 5, also known as S2API.

Try the latest linuxtv.org repository, which is known as v4l-dvb. Changes here will go into the next kernel version: How_to_Obtain,_Build_and_Install_V4L-DVB_Device_Drivers.

or alternatively s2-liplianin is usually quite up to date:

hg clone http://mercurial.intuxication.org/hg/s2-liplianin
ln -s s2-liplianin s2  [scan-s2 Makefile expects this]
cd s2-liplianin
make
sudo make install
sudo reboot

Scan for channels with scan-s2:

hg clone http://mercurial.intuxication.org/hg/scan-s2
cd scan-s2
[check the INCLUDE line in the Makefile points to the s2 directory]
make
./scan-s2 [options] -o zap dvb-s/[satellitefile] > ~/channels.conf

and tune with szap-s2:

hg clone http://mercurial.intuxication.org/hg/szap-s2
cd szap-s2
[check the INCLUDE line in the Makefile points to the s2 directory]
make
./szap-s2 [options] -c ~/channels.conf [channel]

Or install one of the main multimedia applications like Kaffeine or MythTV.

Multiproto driver

A driver using the obsolete multiproto API may be installed as follows.

Installing on Debian (2.6.18-6-686) etch with Multiproto diver (!!!DVB-S2 Don`t Work. Only DVB-S!!!). Install new Debian (2.6.18-6-686)

cd /usr/src
apt-get install linux-headers-2.6.18-6-686
apt-get install linux-source-2.6.18
apt-get install mercurial
hg clone http://jusst.de/hg/multiproto   [or maybe multiproto-plus]
cd multiproto
make
make install
reboot
dmesg

External Links


TT S2-3200