Mailing List archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[linux-dvb] Skystar2 misc changes committed, testing wanted



Hi all,

I just committed a not trivial patch to skystar2.c.
Changelog:
- pid addition/removal and open_whole_bandwidth() reworked:
  add_pid() and remove_pid() handle ref count tables only;
  add_hw_pid() and remove_hw_pid() set the hardware, enabling/disabling
  whole_bandwidth when necessary;
  pid==0x2000 is considered special by  *_hw_* functions only.
- write_reg_op() replaced by write_reg_bitfield(), simpler, cleaner
    instead of:
      write_reg_op(adapter,0x456,3,0xffffe000,0x1234);
    we have now:
      write_reg_bitfield(adapter,0x456,0x00001fff,0x1234);
- better usage of u8, u16, u32, int
- changed hexadecimal values to lowercase
- improved enable_hw_filters and related log messages
- lot of coding styling fixes

The first change is a simplification/reorganization of all the
pid handling stuff. Less duplication of code, better readability.
This code is moving towards final shape, but it's not there yet.

The second change touches a lot of parts. The ideas behind it are
that it's easier to spot errors if the mask is not negated and
that the op=1,2,3 for or/and/and+or was terribly ugly.
A careful examination of the diff would be useful to detect a
wrong conversion I may have introduced somewhere.

The other changes are less critical. Note that enable_hardware_filters
defaults now to 2 (i.e., try to activate all the 6+32 filters).
The diff is somewhat inflated because of the styling fixes.

Let me know if you see something wrong or if the code behaves
incorrectly.

Thank you.
-- 
   Roberto Ragusa    r.ragusa at libero.it


-- 
Info:
To unsubscribe send a mail to ecartis@linuxtv.org with "unsubscribe linux-dvb" as subject.



Home | Main Index | Thread Index