When pressing the key 2 to cut a recording with marks, give and error and say "Index file regeneration failed!" and the index is not generated. Fisrt time the recording is played, the index is regenerated properly. That is with vdr 2.8.2 and all the recordings.
Best regards.
Jose Alberto Reguero
On 13.07.26 12:04 AM, Jose Alberto Reguero wrote:
When pressing the key 2 to cut a recording with marks, give and error and say "Index file regeneration failed!" and the index is not generated. Fisrt time the recording is played, the index is regenerated properly. That is with vdr 2.8.2 and all the recordings.
Please be more specific about the exact sequence of actions to reprodce this.
Klaus
Just make marks, some time by hand, other times with markad, and then press key 2 to cut the recording. The disk is a ntfs disk mounted in /video. I start vdr with a user systemd service. Nothing extrange. When pressing 2 it say "Regenerating index file" and then give the error.
Best regards. Jose Alberto Reguero
El lun, 13 jul 2026, 9:34, Klaus Schmidinger Klaus.Schmidinger@tvdr.de escribió:
On 13.07.26 12:04 AM, Jose Alberto Reguero wrote:
When pressing the key 2 to cut a recording with marks, give and error
and say "Index file regeneration failed!" and the index is not generated. Fisrt time the recording is played, the index is regenerated properly. That is with vdr 2.8.2 and all the recordings.
Please be more specific about the exact sequence of actions to reprodce this.
Klaus
vdr mailing list -- vdr@linuxtv.org To unsubscribe send an email to vdr-leave@linuxtv.org
On 13.07.26 1:18 PM, Jose Alberto Reguero wrote:
Just make marks, some time by hand, other times with markad, and then press key 2 to cut the recording. The disk is a ntfs disk mounted in /video. I start vdr with a user systemd service. Nothing extrange. When pressing 2 it say "Regenerating index file" and then give the error.
So I assume that there is no index file when you start playing the recording, otherwise it should say "Regenerating index file" right after you start replay. Why is there no index file? And how did you manually set marks without it?
Klaus
El lun, 13 jul 2026, 13:58, Klaus Schmidinger Klaus.Schmidinger@tvdr.de escribió:
On 13.07.26 1:18 PM, Jose Alberto Reguero wrote:
Just make marks, some time by hand, other times with markad, and then
press key 2 to cut the recording. The disk is a ntfs disk mounted in /video. I start vdr with a user systemd service. Nothing extrange. When pressing 2 it say "Regenerating index file" and then give the error. So I assume that there is no index file when you start playing the recording, otherwise it should say "Regenerating index file" right after you start replay. Why is there no index file? And how did you manually set marks without it?
Klaus
vdr mailing list -- vdr@linuxtv.org To unsubscribe send an email to vdr-leave@linuxtv.org
The original recording has a index file. But the edited recording don't have a index file. It is created when I start replay. The problem is that the program don't create index file in the edited recording.
Best regards. Jose Alberto Reguero
On 13.07.26 4:43 PM, Jose Alberto Reguero wrote:
... The original recording has a index file. But the edited recording don't have a index file. It is created when I start replay. The problem is that the program don't create index file in the edited recording.
Editing (with key '2' or --edit) can't be done without a proper index file. You need to generate the index before starting the editing process.
Klaus