[linux-dvb] bt878(0): IRQ lockup, cleared int mask

Travel Factory S.r.l. mc8647tv at mclink.it
Thu Aug 4 14:49:52 CEST 2005

I have an old Asus terminator with Via chipset and I have the same problems.

I think that it's clear the problem resides in the bt878 chip buffer that is too short: when it asks the PC to empty it via an IRQ, the PC doesn't react as quickly as needed and the buffer overflows.

Somebody has it working flawlessy, others have big problems in every case, others have problems only using some features of the MB or other PCI cards.

>From what I read (please follow an old thread by Hamish) the reasons for these behaviour may be different but we usually have this when other actions are being performed on the PC and all these actions have data moving in the PC (can be a SATA disk recording or a lan card heavily used for NFS).

I personally have running time of more than an hour just watching TV, but as soon as I start recording or remotely access the PC I have problems.

I don't know the internals of drivers/PCI/DMA very deeply but some ideas are:

r1) higher priority IRQ are being served. 
The drivers serving the IRQ may be disabling IRQs for a too long time due to badly written code or to cheap cards with small buffers that also ask for IRQ very often

r2) no DMA channels available or PCI bus busy, as I think in the case of SATA

There were different solutions proposed, but they may not work (as happens to me):

s1) lower threshould for buffer
you anticipate the moment in which the bt878 raises the IRQ so you have more time before buffer fills. 

s2) you raise the number of warning before giving up serving IRQ
worked for somebody but stream may be seriously corrupted

s3) move the card to another slot
sometimes mobo chipsets have more than one PCI bus (surely server chipsets have). Very verbose "lspci" gives you info on PCI busses. It may also help to put the board on the slot closest to AGP... it's always said it's the quickest one

s4) changing PCI latency
I actually don't know what it means but I did and it didn't work. It solved to others so you should give a try

I want to add that I tried the card in another PC with an Intel MB and Windows 2k, with latest drivers and all. I have problems also on this PC (it also has shared VGA ram) but I'm not sure it's exactly the same problem.


More information about the linux-dvb mailing list