[linux-dvb] Nova-T USB2 with vdr...no DVB stream!

Laurence Abbott laz at club-burniston.co.uk
Tue Dec 13 10:55:59 CET 2005


I've been trying to get a Nova-T USB2 going for a few weeks now.

I have got it so that hotplug loads the firmware as needed and
everything looks great. I can tune with tzap and a
'cat /dev/dvb/adaptor0/dvr0 > file' gives me a video stream that I can
play back with mplayer, etc. All looks good. Until I try to get it going
with vdr, that is!

With an older version of 'scan', I had to extend the filter timeout or
it would only return the channels on the last-tuned multiplex: I think
this just worked when I tried it with a CVS version of 'scan'.

I'm suspicious that this is the problem that I have with vdr: it doesn't
wait for long enough to tune. vdr finds it as a DVB device and tries to
use it but I never get a video stream from it from vdr! I also have a
PCI Nova-T in the same system and that works fine, so I know that the
vdr setup works (at least with that card!).

Is anyone using one of these USB2 devices successfully with vdr? Or have
they changed something in the latest revision of the device which breaks
something? I have tried drivers from and 2.6.14 kernels but
they both give the same result.

I have yet to try CVS drivers because I have to hack the drivers to get
the remote on my PCI Nova-T to work properly, unless that has changed
recently! Has anyone got the remote on the USB2 device to work? A quick
test with evtest gave me a keymapping but nothing appeared when I
pressed buttons (apart from the LED flashing!).

This must be so close to working...do I need to hack vdr to extend a
timeout for this to work?



More information about the linux-dvb mailing list