[linux-dvb] Nova-T USB2 with vdr...no DVB stream!

Laurence Abbott laz at club-burniston.co.uk
Tue Dec 13 11:37:49 CET 2005

On Tue, 2005-12-13 at 11:20 +0100, Patrick Boettcher wrote:
> On Tue, 13 Dec 2005, Laurence Abbott wrote:
> > With an older version of 'scan', I had to extend the filter timeout or
> > it would only return the channels on the last-tuned multiplex: I think
> > this just worked when I tried it with a CVS version of 'scan'.
> Are you using the box on a USB1.1 port? When running on a USB1.1 port the 
> pid filter is activate, ie. eg. when scanning it can take a while until a 
> buffer is filled to be returned to the host-PC.

It's on a USB 2 port on an Epia board. I think I have modules for both
USB 1.1 _and_ USB 2 (should I still need to build the USB 1.1. modules
for backward compatibility with older devices?). I'm pretty sure that it
is listed as USB 2.0 when the kernel finds it.

> > I'm suspicious that this is the problem that I have with vdr: it doesn't
> > wait for long enough to tune. vdr finds it as a DVB device and tries to
> > use it but I never get a video stream from it from vdr! I also have a
> > PCI Nova-T in the same system and that works fine, so I know that the
> > vdr setup works (at least with that card!).
> I use the box for almost one year now daily with VDR but on a USB2.0 port.

I only bought mine in the last couple of weeks so another option is that
they've changed something inside subtly, like they've done before! When
I get home, I'll post the actual model and revision number stuck on the

> > Is anyone using one of these USB2 devices successfully with vdr? Or have
> > they changed something in the latest revision of the device which breaks
> > something? I have tried drivers from and 2.6.14 kernels but
> > they both give the same result.
> >
> > I have yet to try CVS drivers because I have to hack the drivers to get
> > the remote on my PCI Nova-T to work properly, unless that has changed
> > recently! Has anyone got the remote on the USB2 device to work? A quick
> > test with evtest gave me a keymapping but nothing appeared when I
> > pressed buttons (apart from the LED flashing!).
> I'm also using the remote daily. It is a bit clumsy, but it works.

For me, I have always had to change the key-mapping in the driver source
to get the remote on the PCI card working with the correct keys: I think
the driver was written for the remote which is packaged in the rest of
Europe, and the UK one has slightly different mappings so only half of
the keys work!

> > This must be so close to working...do I need to hack vdr to extend a
> > timeout for this to work?
> I don't think so. Is it also a problem when you want to watch a channel 
> which from a channels.conf which was created by the PCI card? If so, could 
> you run femon while VDR is working with the Box and see if the card has a 
> lock.

I must admit that I've thought of trying femon but always forget once
I'm testing stuff!!

If I run vdr with just the USB device, I just get a black screen. I
_don't remember_ getting lots of 'channel not available' messages, so I
think it is tuning OK. If a timer is active, it restarts every few
seconds, presumably because it hasn't received any data to record!

If I change channels with SVDRP, it seems to change channel just a bit
too quickly, which makes me suspicious that it isn't tuning properly.

More testing...



More information about the linux-dvb mailing list