[linux-dvb] Problems with Nova T USB 2.0 Tuning

Malcolm Smith malc at porsche.demon.co.uk
Wed May 4 09:50:34 CEST 2005


Patrick Boettcher wrote:

> Hi Malc,
>
> On Tue, 3 May 2005, Malc wrote:
>
>> The signal to the box is good, (checked with another Nova T pci card),
>>
>> The USB box seems to install ok (see kernel below), but I cannot get 
>> scan or tzap to work... It seems to find the first multiplex, but not 
>> the rest (see trace below)
>>
>> Is it something to do with the "will use the device's hw PID 
>> filter.", if so how do I use it? or have I done something wrong here
>
>
>> May  3 21:34:37 firebird kernel: dvb-usb: MAC address: 00:0d:fe:02:45:d5
>
>
> Btw. is this MAC address correct? (see the bottom of your box). 
> Reading this MAC address is just a guess in the driver.
>
>> initial transponder 754166670 0 3 9 1 0 0 0
>>
>>>>> tune to: 
>>>>
>> WARNING: filter timeout pid 0x0010
>
>
> This is because the PID filter is in use. For this box I needed to 
> have 4096 bytes URB buffers (for some reason smaller ones crashed my 
> system).
> When only one pid is filtered (especially section PIDs such as NIT 
> 0x0010) the URBs will return very lately (because they won't get 
> filled enough).
>
> A solution sometimes is to raise the filter-timeout by saying:
>
> dvbscan -5
>
Ok... the -5 option gives me a full list of channels (Same as I get with 
the PCI card!).. excellent!

>> ......#./tzap "BBC ONE"
>> using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
>> reading channels from file '/root/.tzap/channels.conf'
>> tuning to 754166670 Hz
>> video pid 0x0258, audio pid 0x0259
>
>
> Wow, that is strange. Can you please paste the line of the 
> channels.conf for this channel?


Doh! the problem was an out of date channels.conf (and therefore wrong 
pids! - read the output!).... with the extended scan I've been to 
confirm all the channels.... thanks for the prompt help.

Now to set it up in MythTV!

-malc-

btw. The instructions were pretty straightforward... you might want to 
remind people to ensure that hotplug is installed (I had to apt-get 
install them). Beyond that, I just compiled and installed!

>
> regards
> Patrick.
>
> -- 
>   Mail: patrick.boettcher at desy.de
>   WWW:  http://www.wi-bw.tfh-wildau.de/~pboettch/







More information about the linux-dvb mailing list