[linux-dvb] Yet another Nova-T cx88 question (FC3, modprobe, depmod, udev, pain)

Magnus dvblist at rindeberg.se
Sat May 7 12:26:49 CEST 2005


Hi all!

I'm sorry to have to bother the list with yet another question about
getting the Conexant Nova-T PCI card to work. However, I have tried hard
for several days now and my frustration is rapidly approaching a level
that makes the surroundings suffer :-)

I'm using Fedora Core 3 kernel version 2.6.11-1.14_FC3 and get the
following from /sbin/lsmod:

Module                  Size  Used by
parport_pc             28421  1
lp                     12489  0
parport                40201  2 parport_pc,lp
autofs4                26181  0
sunrpc                164485  1
xfs                   586001  1
exportfs                8641  1 xfs
video                  15813  0
button                  6609  0
battery                 9285  0
ac                      4805  0
md5                     4161  1
ipv6                  259201  10
ohci1394               39129  0
ftdi_sio               34629  0
usbserial              28713  1 ftdi_sio
ieee1394              309145  1 ohci1394
ohci_hcd               25685  0
ehci_hcd               39501  0
cx8800                 30988  0
cx88xx                 50592  1 cx8800
i2c_algo_bit            9033  1 cx88xx
video_buf              21764  2 cx8800,cx88xx
ir_common               7044  1 cx88xx
tveeprom               11800  1 cx88xx
v4l1_compat            12932  1 cx8800
v4l2_common             5504  1 cx8800
btcx_risc               4488  2 cx8800,cx88xx
videodev                9665  2 cx8800,cx88xx
i2c_nforce2             6721  0
i2c_core               21953  4 cx88xx,i2c_algo_bit,tveeprom,i2c_nforce2
snd_intel8x0           34049  0
snd_ac97_codec         71097  1 snd_intel8x0
snd_pcm_oss            51953  0
snd_mixer_oss          18241  1 snd_pcm_oss
snd_pcm                99657  3 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_timer              33093  1 snd_pcm
snd                    56741  6
snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore              10785  1 snd
snd_page_alloc          9669  2 snd_intel8x0,snd_pcm
forcedeth              22849  0
floppy                 64753  0
ext3                  131145  2
jbd                    82777  1 ext3
dm_mod                 59221  2
sata_sil                8645  4
libata                 46789  1 sata_sil
sd_mod                 19265  5
scsi_mod              139817  2 libata,sd_mod

dmesg:

cx88[0]: subsystem: 0070:9002, board: Hauppauge Nova-T DVB-T
[card=18,autodetected]
cx88[0]: hauppauge eeprom: model=90002, tuner=76
cx88[0]: registered IR remote control
cx88[0]/0: found at 0000:01:0a.0, rev: 5, irq: 5, latency: 32, mmio:
0xe3000000
cx88[0]/0: registered device video0 [v4l2]
cx88[0]/0: registered device vbi0

As far as I can see the listings above are "Good News"(tm) but the thing
is that I don't get any /dev/dvb directory!

Could this be due to not all needed modules being loaded, and in that
case which modules are needed and how do I load them?

Or, as an alternative - could this be one of the udev bugs that I've
been reading about? Any workarounds?

I have tried to run the makedvb.sh script to create the devices by hand
but the devices cannot be opened:

[root at tv1 ~]# . ./makedvb.sh
Creating DVB devices in /dev/dvb/adapter0
Creating DVB devices in /dev/dvb/adapter1
Creating DVB devices in /dev/dvb/adapter2
Creating DVB devices in /dev/dvb/adapter3

[root at tv1 linuxtv-dvb-apps-1.1.0]# util/szap/tzap RTL
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
ERROR: failed opening '/dev/dvb/adapter0/frontend0' (No such device or address)

I'm grateful for any and all ideas!

Many thanks in advance!

// Magnus

P.S. I'm somewhat of a noob when it comes to linux so I'd prefer an example
modprobe.conf instead of advice such as "load the correct modules using modprobe" :-)






More information about the linux-dvb mailing list