[linux-dvb] Pinnacle mediacenter 300i

Ville Ruokolainen ville at ruokolainen.com
Tue May 10 00:33:52 CEST 2005



Hi, I have a same problem.
Allmost.

I made same things in same order what people adviced.

Followed these "instructions":
http://www.linuxtv.org/pipermail/linux-dvb/2005-March/000785.html



Ok, I got -allmos- my card working.
But then something happened and nothing works anymore :D

lsmod

Module                  Size  Used by
saa7134_dvb             5508  0
mt352                   7428  1 saa7134_dvb
video_buf_dvb           5508  1 saa7134_dvb
tda1004x               14980  1 saa7134_dvb
tda9887                13848  0
tuner                  26920  0
saa7134               104404  1 saa7134_dvb
video_buf              18436  3 saa7134_dvb,video_buf_dvb,saa7134
ir_common               7300  1 saa7134

dmesg | grep saa7134

(cutted card list what isn't important in my opinion)

root at scourge:/dev# dmesg | grep saa7134
saa7134[0]: found at 0000:01:08.0, rev: 1, irq: 16, latency: 32, mmio:
0xec000000
saa7134: <rant>
saa7134:  Congratulations!  Your TV card vendor saved a few
saa7134:  cents for a eeprom, thus your pci board has no
saa7134:  subsystem ID and I can't identify it automatically
saa7134: </rant>
saa7134: I feel better now.  Ok, here are the good news:
saa7134: You can use the card=<nr> insmod option to specify
saa7134: which board do you have.  The list:

saa7134:   card=50 -> Pinnacle PCTV 300i DVB-T + PAL           11bd:002d

saa7134[0]: subsystem: 1131:0000, board: UNKNOWN/GENERIC
 [card=0,autodetected] saa7134[0]: board init: gpio is cc04000
saa7134[0]: Huh, no eeprom present (err=-5)?
saa7134[0]: registered device video0 [v4l2]
saa7134[0]: registered device vbi0
saa7134[0]/audio: audio carrier scan failed, using 5.500 MHz [default]
saa7134[0]: found at 0000:01:08.0, rev: 1, irq: 16, latency: 32, mmio:
0xec000000
saa7134[0]: subsystem: 1131:0000, board: Pinnacle PCTV 300i DVB-T + PAL
[card=50,insmod option]
saa7134[0]: board init: gpio is cc04000
saa7134[0]: Huh, no eeprom present (err=-5)?
saa7134[0]: registered device video0 [v4l2]
saa7134[0]: registered device vbi0
saa7134[0]/audio: audio carrier scan failed, using 5.500 MHz [default]
saa7134[0]: pinnacle 300i dvb setup
saa7134[0]: frontend initialization failed
saa7134[0]: found at 0000:01:08.0, rev: 1, irq: 16, latency: 32, mmio:
0xec000000

This comes _three_ times (I know that I messed something but don't know what / 
how to fix it)

lscpi -v

root at scourge:/# lspci -v
00:00.0 Host bridge: nVidia Corporation nForce2 AGP (different version?) (rev 
c1)
        Flags: bus master, 66Mhz, fast devsel, latency 0
        Memory at e8000000 (32-bit, prefetchable) [size=32M]
        Capabilities: [40] AGP version 3.0
        Capabilities: [60] #08 [2001]

00:00.1 RAM memory: nVidia Corporation nForce2 Memory Controller 1 (rev c1)
        Subsystem: nVidia Corporation: Unknown device 0c17
        Flags: 66Mhz, fast devsel

00:00.2 RAM memory: nVidia Corporation nForce2 Memory Controller 4 (rev c1)
        Subsystem: nVidia Corporation: Unknown device 0c17
        Flags: 66Mhz, fast devsel

00:00.3 RAM memory: nVidia Corporation nForce2 Memory Controller 3 (rev c1)
        Subsystem: nVidia Corporation: Unknown device 0c17
        Flags: 66Mhz, fast devsel

00:00.4 RAM memory: nVidia Corporation nForce2 Memory Controller 2 (rev c1)
        Subsystem: nVidia Corporation: Unknown device 0c17
        Flags: 66Mhz, fast devsel

00:00.5 RAM memory: nVidia Corporation nForce2 Memory Controller 5 (rev c1)
        Subsystem: nVidia Corporation: Unknown device 0c17
        Flags: 66Mhz, fast devsel

00:01.0 ISA bridge: nVidia Corporation: Unknown device 0080 (rev a3)
        Subsystem: nVidia Corporation: Unknown device 5b25
        Flags: bus master, 66Mhz, fast devsel, latency 0
        Capabilities: [48] #08 [01e1]

00:01.1 SMBus: nVidia Corporation: Unknown device 0084 (rev a1)
        Subsystem: nVidia Corporation: Unknown device 5b25
        Flags: 66Mhz, fast devsel, IRQ 5
        I/O ports at e500 [size=32]
        Capabilities: [44] Power Management version 2

00:02.0 USB Controller: nVidia Corporation: Unknown device 0087 (rev a1) 
(prog-if 10 [OHCI])
        Subsystem: nVidia Corporation: Unknown device 5b25
        Flags: bus master, 66Mhz, fast devsel, latency 0, IRQ 20
        Memory at ec103000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: [44] Power Management version 2

00:02.1 USB Controller: nVidia Corporation: Unknown device 0087 (rev a1) 
(prog-if 10 [OHCI])
        Subsystem: nVidia Corporation: Unknown device 5b25
        Flags: bus master, 66Mhz, fast devsel, latency 0, IRQ 21
        Memory at ec104000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: [44] Power Management version 2

00:02.2 USB Controller: nVidia Corporation: Unknown device 0088 (rev a2) 
(prog-if 20 [EHCI])
        Subsystem: nVidia Corporation: Unknown device 5b25
        Flags: bus master, 66Mhz, fast devsel, latency 0, IRQ 21
        Memory at ec105000 (32-bit, non-prefetchable) [size=256]
        Capabilities: [44] #0a [2098]
        Capabilities: [80] Power Management version 2

00:04.0 Bridge: nVidia Corporation: Unknown device 008c (rev a3)
        Subsystem: nVidia Corporation: Unknown device 5b25
        Flags: bus master, 66Mhz, fast devsel, latency 0, IRQ 21
        Memory at ec100000 (32-bit, non-prefetchable) [size=4K]
        I/O ports at e000 [size=8]
        Capabilities: [44] Power Management version 2

00:06.0 Multimedia audio controller: nVidia Corporation: Unknown device 008a 
(rev a1)
        Subsystem: DFI Inc: Unknown device 1001
        Flags: bus master, 66Mhz, fast devsel, latency 0, IRQ 20
        I/O ports at e100 [size=256]
        I/O ports at e200 [size=128]
        Memory at ec101000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: [44] Power Management version 2

00:08.0 PCI bridge: nVidia Corporation: Unknown device 008b (rev a3) (prog-if 
00 [Normal decode])
        Flags: bus master, 66Mhz, fast devsel, latency 0
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=32
        I/O behind bridge: 0000d000-0000dfff
        Memory behind bridge: ec000000-ec0fffff

00:09.0 IDE interface: nVidia Corporation: Unknown device 0085 (rev a3) 
(prog-if 8a [Master SecP PriP])
        Subsystem: nVidia Corporation: Unknown device 5b25
        Flags: bus master, 66Mhz, fast devsel, latency 0
        I/O ports at f000 [size=16]
        Capabilities: [44] Power Management version 2

00:0b.0 IDE interface: nVidia Corporation: Unknown device 008e (rev a3) 
(prog-if 85 [Master SecO PriO])
        Flags: bus master, 66Mhz, fast devsel, latency 0, IRQ 22
        I/O ports at 09f0 [size=8]
        I/O ports at 0bf0 [size=4]
        I/O ports at 0970 [size=8]
        I/O ports at 0b70 [size=4]
        I/O ports at ea00 [size=16]
        I/O ports at eb00 [size=128]
        Capabilities: [44] Power Management version 2

00:1e.0 PCI bridge: nVidia Corporation nForce2 AGP (rev c1) (prog-if 00 
[Normal decode])
        Flags: bus master, 66Mhz, medium devsel, latency 32
        Bus: primary=00, secondary=02, subordinate=02, sec-latency=32
        Memory behind bridge: ea000000-ebffffff
        Prefetchable memory behind bridge: e0000000-e7ffffff

01:08.0 Multimedia controller: Philips Semiconductors SAA7134 (rev 01)
        Subsystem: Philips Semiconductors: Unknown device 0000
        Flags: bus master, medium devsel, latency 32, IRQ 16
        Memory at ec000000 (32-bit, non-prefetchable) [size=1K]
        Capabilities: [40] Power Management version 1

01:0d.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller 
(rev 80) (prog-if 10 [OHCI])
        Subsystem: DFI Inc: Unknown device 1006
        Flags: bus master, medium devsel, latency 32, IRQ 16
        Memory at ec001000 (32-bit, non-prefetchable) [size=2K]
        I/O ports at d000 [size=128]
        Capabilities: [50] Power Management version 2

02:00.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5200] 
(rev a1) (prog-if 00 [VGA])
        Flags: bus master, 66Mhz, medium devsel, latency 248, IRQ 19
        Memory at ea000000 (32-bit, non-prefetchable) [size=16M]
        Memory at e0000000 (32-bit, prefetchable) [size=128M]
        Expansion ROM at <unassigned> [disabled] [size=128K]
        Capabilities: [60] Power Management version 2
        Capabilities: [44] AGP version 3.0



lspci -n

root at scourge:/# lspci -n
00:00.0 Class 0600: 10de:01e0 (rev c1)
00:00.1 Class 0500: 10de:01eb (rev c1)
00:00.2 Class 0500: 10de:01ee (rev c1)
00:00.3 Class 0500: 10de:01ed (rev c1)
00:00.4 Class 0500: 10de:01ec (rev c1)
00:00.5 Class 0500: 10de:01ef (rev c1)
00:01.0 Class 0601: 10de:0080 (rev a3)
00:01.1 Class 0c05: 10de:0084 (rev a1)
00:02.0 Class 0c03: 10de:0087 (rev a1)
00:02.1 Class 0c03: 10de:0087 (rev a1)
00:02.2 Class 0c03: 10de:0088 (rev a2)
00:04.0 Class 0680: 10de:008c (rev a3)
00:06.0 Class 0401: 10de:008a (rev a1)
00:08.0 Class 0604: 10de:008b (rev a3)
00:09.0 Class 0101: 10de:0085 (rev a3)
00:0b.0 Class 0101: 10de:008e (rev a3)
00:1e.0 Class 0604: 10de:01e8 (rev c1)
01:08.0 Class 0480: 1131:7134 (rev 01)
01:0d.0 Class 0c00: 1106:3044 (rev 80)
02:00.0 Class 0300: 10de:0322 (rev a1)






(day after of writing 99% of the message)

 sombody told me to look dmesg | tail 

found this interesting (there was something about agpcard what doesn't 
interest me at the moment)
mt352_read_register: readreg error (reg=127, ret==-5)
saa7134[0]: frontend initialization failed



My tv-card is Pinnacle Mediacenter 300i
and my linux kernel is 2.6.12-rc4

Using kernel based drivers, they seem to work quite fine.


I hope that I gave enough technical data to help me.
If I didn't, I will give more :)



(direct mailing address: ville at ruokolainen.com
   				     scourge at isokaato.com)

Thanks in advance.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.linuxtv.org/pipermail/linux-dvb/attachments/20050510/1213d65a/attachment.htm


More information about the linux-dvb mailing list