[linux-dvb] mt352 readreg error avermedia 771

Miguel Yarza yarza at euskalnet.net
Wed Sep 14 01:49:54 CEST 2005

Paul Wheeler wrote:

>I have searched the list and the net to try and find a solution to this but 
>so far unsuccessfull. The problem is that the dvb frontend is not found. I 
>have tried on a different motherboard and still same problem however a 
>different computer it works fine.
>I get the following in dmesg
>mt352_read_register: readreg error (reg=127, ret==-5)
>dvb-bt8xx: A frontend driver was not found for device 109e/0878 
>subsystem 1461/0771
>In both machines I am using Gentoo-2.6.13-r1 kernel.
>The motherboards that it fails on are:
>asus p4p800s-x and an aopen intel 865 board
>it works fine in my shuttle sn41g2.
>I have tried all possible hardware fixes. 
>The card is recognized to begin with on the motherboard(asus) but after a 
>reboot stops and hasnt worked since!!
>I have noticed others who have had this problem before but no solution is 
>posted. Could people possible post what motherboard they have if the card 
>works or how they solved this problem if they had it before.
Same problem here:
 - the card works great with Shuttle SN41G2 k7 nforce2 chipset
 - but on a K7 ASUS A7N8X-E DELUXE (k7 nforce2 chipset too)  "modprobe 
dvb-bt8xx" says:

Sep 14 01:17:23 topocasa kernel: DVB: registering new adapter (bttv0).
Sep 14 01:17:23 topocasa kernel: mt352_read_register: readreg error 
(reg=127, ret==-5)
Sep 14 01:17:23 topocasa kernel: dvb-bt8xx: A frontend driver was not 
found for device 109e/0878 subsystem 1461/0771

Same error with different kernels since 2.6.10 and snapshots from cvs, 
last try with 2.6.12-6 from debian.
In the hardware front tried with different slots and card combinations, 
no luck.
A difference with Paul's card behavior is that mine has never been 



More information about the linux-dvb mailing list