[linux-dvb] mt352 readreg error avermedia 771

Paul Wheeler paulrwheeler at gmail.com
Thu Sep 15 15:36:58 CEST 2005

Ronnie, Miguel thanks for both of your quick replies.

Right I from my understanding of the problems I believe that a "race" is 
going on as to when this card is detected. I think that it is most likely in 
the i2c part of the driver (more justification below). So I have two 

1) Seeing as the card works in most cases do the driver writers have the 
time and inclination to help find this bug? I am happy to put a lot of 
effort into testing and narrowing down where the problem might lie however I 
have done no kernel coding (but do know c++ well and am happy to play with 
kernel source code but wont know what am doing with it). I dont want to put 
all this effort in though for noone to use it.

2) Is this the right list for the problem? It is a dvb card though I dont 
know whether it is the mt352.c or the bttv-i2c.c files (maybe even some more 
generic i2c code) AFAIK the mt352.c is 'maintained' on this list whereas the 
bttv-i2c.c is on the v4l list. Is this correct?

My reasons for thinking it is a race: My problem started when i changed the 
power supply, thats it worked fine before changed the power supply and 
stopped. I tried the card in another machine it worked so thought I must 
have damaged the motherboard. So changed the motherboard and the same 
problem. The card worked in one machine and not another even though both had 
identical kernels. However I thought as a last attempt would try a knoppix 
CD to see if that worked and it did so installed vanilla- kernel 
and it worked again. So it consistently works with 2.6.11 and fails with 
2.6.13 on one machine but works with 2.6.13 on anaother. So the problem can 
be sorted by both hardware and software changes (seemingly independent). If 
it can be assumed that both of these cause and solve the same bug then the 
bug must be in both hardware and software, the only way this could happen is 
a "race" which is affected by hardware.

This fits with both Ronny and Miguel's experience. Ronny can seem to affect 
the race by leaving his power supply plugged in.

Ronny, Miguel I would be interested to know if either of you have any 
problems with the either the vanilla <> kernel or 
the latest version of knoppix 3.9? If you dont then this race has been 
introduced since then. I would also like to hear from anyone else who has 
had this problem and if it is consistent/different from above.

Many thanks


P.S. bit more info. The problem only happens at boot, if it is detected fine 
it works perfectly till next reboot, if not then wont work till (possible) 
next reboot. I have had the card working then reboot the machine without 
changing anything software wise and it stops working.

On 9/14/05, Miguel Yarza <yarza at euskalnet.net> wrote:
> Paul Wheeler wrote:
> >I have searched the list and the net to try and find a solution to this 
> but
> >so far unsuccessfull. The problem is that the dvb frontend is not found. 
> I
> >have tried on a different motherboard and still same problem however a
> >different computer it works fine.
> >
> >I get the following in dmesg
> >
> >mt352_read_register: readreg error (reg=127, ret==-5)
> >dvb-bt8xx: A frontend driver was not found for device 109e/0878
> >subsystem 1461/0771
> >
> >In both machines I am using Gentoo-2.6.13-r1 kernel.
> >
> >The motherboards that it fails on are:
> >
> >asus p4p800s-x and an aopen intel 865 board
> >
> >it works fine in my shuttle sn41g2.
> >
> >I have tried all possible hardware fixes.
> >
> >The card is recognized to begin with on the motherboard(asus) but after a
> >reboot stops and hasnt worked since!!
> >
> >I have noticed others who have had this problem before but no solution is
> >posted. Could people possible post what motherboard they have if the card
> >works or how they solved this problem if they had it before.
> >
> >Cheers
> >
> >Paul
> >
> >
> Same problem here:
> - the card works great with Shuttle SN41G2 k7 nforce2 chipset
> - but on a K7 ASUS A7N8X-E DELUXE (k7 nforce2 chipset too) "modprobe
> dvb-bt8xx" says:
> Sep 14 01:17:23 topocasa kernel: DVB: registering new adapter (bttv0).
> Sep 14 01:17:23 topocasa kernel: mt352_read_register: readreg error
> (reg=127, ret==-5)
> Sep 14 01:17:23 topocasa kernel: dvb-bt8xx: A frontend driver was not
> found for device 109e/0878 subsystem 1461/0771
> Same error with different kernels since 2.6.10 and snapshots from cvs,
> last try with 2.6.12-6 from debian.
> In the hardware front tried with different slots and card combinations,
> no luck.
> A difference with Paul's card behavior is that mine has never been
> recognized.
> Cheers
> Miguel
> _______________________________________________
> linux-dvb mailing list
> linux-dvb at linuxtv.org
> http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.linuxtv.org/pipermail/linux-dvb/attachments/20050915/e82340f0/attachment-0001.htm

More information about the linux-dvb mailing list