[linux-dvb] CVS Problems, and T200 unrecognised again (was RE: Compro DVB-T300 Remote)

Hartmut Hackmann hartmut.hackmann at t-online.de
Fri Sep 23 23:41:06 CEST 2005

Hi, Andy

I just cross checked:
- fresh download of video4linux and dvb-kernel from anonymous at linuxtv.org
- cd video4linux
- scripts/merge-trees.sh
- make
It compiles cleanly with just 2 warnings about unused symbols in tda8290.c.
I run a kernel 2.6.12 and a gcc 3.3.3.
Could it be that your gcc 4.0 resp. its specfile causes the problems?
Regarding the card detection: I know that there is an issue. It seems to
have 2 eeproms that might collide both on address 0xa0 unless some gpio
magic is done. But not sure yet.
The effect is that the card detection only works after a boot from power
up. As a workaround, please force the card type:
modprobe saa7134 card=71
modprobe saa7134-dvb
(this assumes that the modules are installed).

Good luck

Andy wrote:
>>Doh! Now although it's probably still me doing something stupid
>>(somewhere!), could someone else do a clean checkout from CVS just to
>>check it hasn't been broken? (I know it's very unlikely, but at least
>>it'll prove it's not that).
> Oh well, never mind - I did this as a workaround:
> # <fresh checkout of video4linux and dvb-kernel>
> # cd video4linux
> # sh ./scripts/merge-trees.sh
> # ln -s ../dvb-kernel/linux/drivers/media/dvb/dvb-core/demux.h ./demux.h
> As an aside, should the last line be added to merge-trees.sh???
> But still having compile problems! For every file which includes
> video-buf-dvb.h I get:
> In file included from /data/scratch/dev/dvb/video4linux/saa7134.h:47,
>                  from /data/scratch/dev/dvb/video4linux/saa7134-core.c:38:
> include/media/video-buf-dvb.h:1:20: error: dvbdev.h: No such file or
> directory
> include/media/video-buf-dvb.h:2:20: error: dmxdev.h: No such file or
> directory
> include/media/video-buf-dvb.h:3:23: error: dvb_demux.h: No such file or
> directory
> include/media/video-buf-dvb.h:4:21: error: dvb_net.h: No such file or
> directory
> include/media/video-buf-dvb.h:5:26: error: dvb_frontend.h: No such file or
> directory
> fixdep: /data/scratch/dev/dvb/video4linux/.saa7134-core.o.d is empty
> (saa7134-core.c was the example file here, but it happens to every file
> which directly or indirectly includes vidoe-buf-dvb.h)
> Yet all those files *are* present (symlinked in from the dvb-kernel tree)!
> Now the build continues sucessfully and all .ko objects are created
> (apparently sucessfully). 'make install' has one error:
> install -m 644 -c cx8800.ko cx8802.ko cx88-alsa.ko  cx88-blackbird.ko
> cx88xx.ko cx88-dvb.ko
> /lib/modules/2.6.12-1.1456_FC4/kernel/drivers/media/video/cx88
> install: cannot stat `cx88-alsa.ko': No such file or directory
> ...but completes otherwise sucessfully.
> "modprobe saa7134" works fine and I can see the card reckognised in
> /var/log/messages. However when I run "modprobe saa7134-dvb" the following
> appears in messages:
> Sep 23 16:07:57 alpha kernel: saa7130[0]: Huh? unknown DVB card?
> Sep 23 16:07:57 alpha kernel: saa7130[0]: frontend initialization failed
> Any idea what's going wrong? Getting really peeved now, ended up taking
> several steps backwards here!!! :-s
> (FC4, gcc 4.0.1, kernel 2.6.12-1.1456_FC4 on x86_64)
> Thanks in advance,
> Andy
> _______________________________________________
> linux-dvb mailing list
> linux-dvb at linuxtv.org
> http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb

More information about the linux-dvb mailing list