[linux-dvb] CVS Problems, and T200 unrecognised again (was RE: Compro DVB-T300 Remote)

Hartmut Hackmann hartmut.hackmann at t-online.de
Sat Sep 24 15:35:20 CEST 2005

Hi, Andy

That's strange. It looks like the card type was not accepted. Can
you please check this in the kernel log? It is mentioned in the
initialization messages of the saa7134 module. Pleas ensure also that
the new dvb module got compiled and installed.

Best regards

Andy wrote:
> Hi Hartmut,
> Thanks for checking. I finally worked out it's a weird Fedora issue - the kernel-devel package does *not* put the kernel source 
> in /usr/src/kernels/xxxx, but just the directory tree and Makefiles. After installing the kernel source I then had to copy it into 
> the /usr/src/kernels/xxxx tree. After that, compiled fine (bar a few warnings).
> I'm still having issues with the detection of the card... I do a "modprobe saa7134" and the module sucessfully loads. I have "options saa7134 
> oss=1 card=71" in my modprobe.conf and if I look at /var/log/messages I see the module is loading for my T200 card. The problem comes when 
> loading saa7134-dvb, thats when I get:
> Sep 24 11:30:46 alpha kernel: saa7130[0]: Huh? unknown DVB card?
> Sep 24 11:30:46 alpha kernel: saa7130[0]: frontend initialization failed
> It's silly - this worked fine a week or so ago when I first tried it!!!
> Any ideas what's wrong?
> Thanks,
> Andy
> On Fri Sep 23 22:41 , Hartmut Hackmann hartmut.hackmann at t-online.de> sent:
>>Hi, Andy
>>I just cross checked:
>>- fresh download of video4linux and dvb-kernel from anonymous at linuxtv.org
>>- cd video4linux
>>- scripts/merge-trees.sh
>>- make
>>It compiles cleanly with just 2 warnings about unused symbols in tda8290.c.
>>I run a kernel 2.6.12 and a gcc 3.3.3.
>>Could it be that your gcc 4.0 resp. its specfile causes the problems?
>>Regarding the card detection: I know that there is an issue. It seems to
>>have 2 eeproms that might collide both on address 0xa0 unless some gpio
>>magic is done. But not sure yet.
>>The effect is that the card detection only works after a boot from power
>>up. As a workaround, please force the card type:
>>modprobe saa7134 card=71
>>modprobe saa7134-dvb
>>(this assumes that the modules are installed).
>>Good luck
>>   Fartmut

More information about the linux-dvb mailing list