[linux-dvb] Re: Status of HDTV5 lite? LGDT330X QAM bug?

Michael Krufky mkrufky at m1k.net
Mon Sep 26 17:49:26 CEST 2005

GFarris wrote:

>That bug is fixed!  Without your patch, as soon as I run an analog app, the frontend dies.
Great!  The problem was actually occuring on any kind of video mode 
switch.  Since that last email I wrote, I made even further 
improvements:  I fixed it such that tv, composite, mute and atsc 
(obviously) all work correctly, without killing the frontend.  (I had to 
get composite working in the process, an extra bonus :-D )

S-Video could still break the frontend, because I have not yet 
programmed s-video on this board, as I am currently looking for a 
break-out-box adapter to test this with.  (My break-out-box works just 
fine for composite, as I have already tested that, but the s-video jack 
on it is broken.)

...I'm using a break-out-box that came with an ATI AIW (theatre chipset) 
card that I am NOT using.

>Now if I could figure out why the analog video dies in kdetv and xawtv after I use mplayer 1.0 pre7-r1 from gentoo portage to look at my HD cable stream.  SInce this is all new to me, I don't know if this is a bug in Mplayer, or if something has to be reset to go back to analog.  The only way to restore analog video is to turn off power to the computer---reboot doesn't help.  Tvtime usually still works.
You have to kill azap before using the analog tuner.

You say tvtime usually still works -- I'll take that to mean that yes, 
you DID kill azap.... SO:

Someone in irc mentioned a bug where kdetv and xawtv worked with older 
v4l code, but tvtime did not.  I told this user to upgrade video4linux 
from cvs.  After doing this, kdetv and xawtv did not work correctly 
anymore, but tvtime did.  My guess is that you can probably benefit from 
newer versions of these applications.

That was just a guess... You might want to seek support for those 
respective applications elsewhere (or maybe even on this list... I dont 
know the answer though.)

>Another issue is once in a while I have a problem with QAM256 and I found that if I zap an 8VSB channel then QAM256 will work again.
This is an old bug that we fixed a long time ago... I don't know how 
it's happening for you.  Are you using a kernel-supplied lgdt330x module 
( kernel >= 2.6.12-rcX), or are you using the module currently present 
in dvb-kernel?

If you used the tree-merging scripts, then I must assume that you are in 
fact using the lgdt330x module present in dvb-kernel... In which case, I 
need some more information:

Can you describe the situation in more detail?  IE:
When the problem occurs, what isnt working?  Is it that you cannot get a 
lock at all?  Or are you able to get a lock, but no TS data coming 
through? Please provide the error log (from dmesg) at the point where 
you are unable use QAM.

>Is there a way to just switch modes?  On the Windows side DVICO's program lets you switch from air to cable and analog to digital.
The mode switch is dependant on the type of channel that you're 
zapping.  If you zap a QAM channel, the frontend will go into QAM mode.  
If you zap a VSB channel, the frontend will go into VSB mode.  Is there 
something more that you're asking for, here?

-Michael Krufky

More information about the linux-dvb mailing list