[linux-dvb] Technisat HD2 cannot szap/scan (possible diseqc problem)

Hans Werner HWerner4 at gmx.de
Sat Dec 6 18:07:53 CET 2008

> 2008/12/5 Michel Verbraak <michel at verbraak.org>
> >  Alex,
> >
> > I have the following problem. I'm not able to rotate my rotor with my
> HD2
> > card and any of the drivers (liplianin, v4l-dvb, Manu). I tried GotoX
> diseqc
> > commands as well as the goto position used by scan-s2.
> > As Pavel also has problems with diseqc (switch with A B input) I think
> it
> > is not in the scan-s2 an szap-s2 utilities but in the driver.
> >
> I don't have a rotor nor HD2 card, so I can't help with that.
> I do have 8-1 disecq that works fine with Igor's drivers (previously
> worked
> fine with Manu's drivers as well) and scan-s2 utility using Twinhan 1041
> card.

I have a Twinhan 1041 card and I have problems with the s2-liplianin driver
which I have not fully understood yet.

1) Scan-s2 works for a while but in a long scan I eventually I start getting
"Slave RACK Fail !" messages in dmesg and scan-s2 hangs. Perhaps increasing to
msleep(15) in mantis_ack_wait helps (it hasn't eliminated the problem), but I am not sure.
There are messages in /var/log/messages from stb6100_[set/get]_[frequency/bandwidth]
which say "Invalid parameter". Only shutting down the computer and restarting seems to
recover from this once it has happened.

2) szap-s2 works for a while after a cold start, but I think if you stop it and leave it for
30 seconds or so the card goes into sleep mode and after that szap-s2 hangs. Strangely when
this happens a short scan-s2 run (not long enough to get the "Slave RACK Fail!" problem) can wake
the card up again, and szap-s2 works after that.  But szap-s2 can't wake it up itself and hangs in
get_pmt_pid on the line
if (((count = read(patfd, buf, sizeof(buft))) < 0) && errno == EOVERFLOW){

When it goes into sleep mode I see the following in dmesg:
[  522.821625] _stb0899_read_reg: Reg=[0xf12a], data=58                                                                                        
[  522.821632] stb0899_i2c_gate_ctrl: Disabling I2C Repeater ...                                                                               
[  522.821634] stb0899_write_regs [0xf12a]: 58                                                                                                 
[  522.822681] stb0899_sleep: Going to Sleep .. (Really tired .. :-))

So the Twinhan 1041 is quite useless for me at the moment.

> Few weeks ago Hans Werner applied changes for scan-s2 to work with his
> rotor. Please take a look on rotor.conf file and "-r" option.
> Maybe it will help.

I tested that with an HVR4000 by the way. I'm not aware that the problems I have
with the Twinhan vp1041 are to do with diseqc. When it is working diseqc
works too.

> >
> > I changed the subject because I do not know if Pavels problem is only
> due
> > to diseqc problems.
> >
> > I have another card (twinhan vp-1034 mantis) which should be able to
> rotate
> > my rotor and I will try it next weekend to see if my rotor is not broken
> and
> > I will also have a look into the driver but this will be not easy
> beacuse I
> > do not have schematics or any documentation.
> >
> My 1027 card worked fine with multiproto drivers few months ago (replaced
> it
> with 1041 card)

Release early, release often.

Psssst! Schon vom neuen GMX MultiMessenger gehört? Der kann`s mit allen: http://www.gmx.net/de/go/multimessenger

More information about the linux-dvb mailing list