[linux-dvb] Hauppauge HVR-1800 Analog issues

Jeff DeFouw jeffd at i2k.com
Mon Dec 8 05:00:40 CET 2008

On Sun, Dec 07, 2008 at 09:28:17PM -0500, Josh Borke wrote:
> I recently upgraded to Fedora 10 and decided to try to get my Hauppauge
> HVR-1800 working. I thought everything was working fine and well because I
> could run 'tvtime -d /dev/video0' and 'cat /dev/video1 > /tmp/test.mpg' and
> things worked but then I rebooted and it all went to pot. Now when I run
> 'cat /dev/video1 > /tmp/test.mpg' the output of tvtime becomes wavy and
> distorted. I tried loading both cx25840 and cx23885 with debug=1 but that
> didn't help.  I also tried with the latest v4l-dvb sources
> (v4l-dvb-7100e78482d7) with the same result.
> I've attached the dmesg in hopes of being some help.
> To recap, I can 'tvtime -d /dev/video0' and I get a great picture. As soon
> as I 'cat /dev/video1 > /tmp/test.mpg' the picture goes wavy.

I found the same thing while testing the analog tuner support (which I 
don't normally use).  It only happened the first time after boot.  
Unloading all of the modules (run "make rmmod" in the v4l-dvb sources) 
and reloading them always fixed it for me.  Also, make sure the tuner 
module is loaded after that.  Mine doesn't auto-load for some reason.

Jeff DeFouw <jeffd at i2k.com>

More information about the linux-dvb mailing list