[linux-dvb] dvb-fe-nxt2004.fw not available any more?

CityK CityK at rogers.com
Fri Jan 18 16:39:14 CET 2008

kevin liu wrote:
>     I just tried to get dvb-fe-nxt2004.fw using """perl
> get_dvb_firmware nxt2004"""
> But it seems that the firmware is not there any more.
>     Aver move it to another place, 

I checked last night and its working fine. I'm willing to bet that when 
you tried you had ran it simply as "user" . Examples (which assume that 
you are already operating from the correct directory ... or 
alternatively just pass the correct directory path for the 
get_dvb_firmare script along in the command line below):

$ perl get_dvb_firmware nxt2004
AVerTVHD_MCE_A180_Drv_v1.2.2.16.zip: Permission denied
wget failed - unable to download firmware at get_dvb_firmware line 372.

Whereas when attempted as the "root" user:

$ sudo perl get_dvb_firmware nxt2004
root's password:
=> `AVerTVHD_MCE_A180_Drv_v1.2.2.16.zip'
Resolving www.aver.com...
Connecting to www.aver.com||:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 156,028 (152K) [application/x-zip-compressed]

156,028 103.05K/s

23:25:54 (102.79 KB/s) - `AVerTVHD_MCE_A180_Drv_v1.2.2.16.zip' saved 

Firmware dvb-fe-nxt2004.fw extracted successfully.
Now copy it to either /usr/lib/hotplug/firmware or /lib/firmware
(depending on configuration of firmware hotplug).

> why we copy as much firmware as possible into
> linuxtv's website, then the perl script will not be any problem?

Distribution rights --- specifically, our lack thereof

More information about the linux-dvb mailing list