[linux-dvb] Support for VP3020 Board

Andrea Cimino andreacimino at gmail.com
Tue Nov 4 21:10:17 CET 2008

Hello to everyone, hoping that this is the right place to post.
I have almost from 2 years a VP3020 CARD (
and seems to be supported as seen on BTTV Gallery
This reports:

chips: 25878-13 et al.
tuner: TU1216/I H P   3112 297 13641D#
pcb: VP3020 V1.0

Feb  9 20:36:42 localhost kernel:
Feb  9 20:36:42 localhost kernel: DST type flags : 0x10 firmware version = 2
Feb  9 20:36:42 localhost kernel: DVB: registering frontend 0 (DST DVB-T)...


Well, some time ago it worked nicely with a Gentoo system.
 Some time ago i upgraded to ubuntu 8.10 and now simply doesn't work,
the interface
dvb frontend does not come up

Here is the log from dmesg:

[ 3949.259468] bttv1: Bt878 (rev 17) at 0000:01:0a.0, irq: 18,
latency: 32, mmio: 0xbfffd000
[ 3949.262776] bttv1: subsystem: ffff:0001 (UNKNOWN)
[ 3949.262785] please mail id, board name and the correct card= insmod
option to video4linux-list at redhat.com
[ 3949.262791] bttv1: using:  *** UNKNOWN/GENERIC ***  [card=0,autodetected]
[ 3949.262846] bttv1: gpio: en=00000000, out=00000000 in=00f500ff [init]
[ 3949.324149] bttv1: tuner type unset
[ 3949.324164] bttv1: i2c: checking for MSP34xx @ 0x80... not found
[ 3949.326059] bttv1: i2c: checking for TDA9875 @ 0xb0... <4>tuner'
2-0060: tuner type not set
[ 3949.329104] not found
[ 3949.329114] bttv1: i2c: checking for TDA7432 @ 0x8a... not found
[ 3949.332159] bttv1: registered device video1
[ 3949.333385] bttv1: registered device vbi1
[ 3949.346064] bt878: AUDIO driver version 0.0.0 loaded

I know that it worked under linux, maybe i am missing something? I spent a lot
of time googling but i couldn't find anything interesting.


More information about the linux-dvb mailing list