<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
  <meta content="text/html;charset=ISO-8859-15"
<body bgcolor="#ffffff" text="#000000">
Maybe this is an hint that will enable you to find the problem. I just
looked at the dmesg messages right after I tried ./simpledvbtune -f
11954 and well this are the messages:<br>
pctv452e_power_ctrl: 1<br>
ioctl32(simpledvbtune:5591): Unknown cmd fd(3)
cmd(80046f57){t:'o';sz:4} arg(ff8c43e8) on /dev/dvb/adapter0/frontend0<br>
lnbp22_set_voltage: 1 (18V=1 13V=0)<br>
lnbp22_set_voltage: 0x72)<br>
ioctl32(simpledvbtune:5591): Unknown cmd fd(3)
cmd(80ac6f53){t:'o';sz:172} arg(ff8c433c) on /dev/dvb/adapter0/frontend0<br>
lnbp22_set_voltage: 2 (18V=1 13V=0)<br>
lnbp22_set_voltage: 0x60)<br>
pctv452e_power_ctrl: 0<br>
Maybe that helps..<br>
Oh I almost forgot. The leds on the Receiver. After loading the kernel
modules they go from orange to green. After trying simpledvbtune they
go from green to orange and never back.<br>
Dominik Kuhlen schrieb:
<blockquote cite="mid:200806092248.01786.dkuhlen@gmx.net" type="cite">
  <pre wrap="">On Sunday 08 June 2008, Michael Schöller wrote:
  <blockquote type="cite">
    <pre wrap="">Dominik Kuhlen schrieb:
    <blockquote type="cite">
      <pre wrap="">Hi,

I have attached a step-by-step howto for these devices

Happy testing,


linux-dvb mailing list
<a class="moz-txt-link-abbreviated" href="mailto:linux-dvb@linuxtv.org">linux-dvb@linuxtv.org</a>
<a class="moz-txt-link-freetext" href="http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb">http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb</a>
    <pre wrap="">Well bad news...it's not working.
I try to notice any difference in my system to your description and well 
it's not much...
My dmesg line:

stb0899_get_dev_id: Device ID=[3], Release=[1]

Your dmesg line:

stb0899_get_dev_id: Device ID=[3], Release=[0]

all other dmesg messages are identical.

 next difference

ls -l /dev/dvb/adapter0/
# total 0
# crw------- 1 schomi root 212, 4 Jun  7 15:37 demux0
# crw------- 1 schomi root 212, 5 Jun  7 15:37 dvr0
# crw------- 1 schomi root 212, 3 Jun  7 15:37 frontend0
# crw------- 1 schomi root 212, 7 Jun  7 15:37 net0

well just do be sure I also tried chmod a+rw * but that didn't change anything. Well since schomi is my user I think that should be ok...

So now to the real problem...
./simpledvbtune -f 11954
using '/dev/dvb/adapter0/frontend0' as frontend
frontend fd=3: type=0
DVBFE_SET_DELSYS: Invalid argument
ioclt: FE_SET_VOLTAGE : 1
High band
tone: 1
dvbfe setparams :  delsys=1 1354MHz / Rate : 27500kBPS
DVBFE_SET_PARAMS: Invalid argument
tuning qpsk failed
  <pre wrap=""><!---->Hmm, this is strange. looks like you are using old drivers or old dvb-core module that doesn't support the new ioctls
Did you load the modules with
insmod ./dvb-core.ko
insmod ./dvb-usb.ko
insmod ./lnbp22.ko
insmod ./stb0899.ko
insmod ./stb6100.ko
insmod ./dvb-usb-pctv452e.ko
to be sure that no old/other modules were used?

  <blockquote type="cite">
    <pre wrap="">@Dominik
By any chance do you live in austria and can visit me ^^.
  <pre wrap=""><!---->No, sorry I don't.
  <blockquote type="cite">
    <pre wrap="">Michael

  <pre wrap=""><!---->

  <pre wrap="">
<hr size="4" width="90%">
linux-dvb mailing list
<a class="moz-txt-link-abbreviated" href="mailto:linux-dvb@linuxtv.org">linux-dvb@linuxtv.org</a>
<a class="moz-txt-link-freetext" href="http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb">http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb</a></pre>