[vdr] XviD movie stuttering (Mplayer)

Pasi Juppo pasi.juppo at iki.fi
Wed Apr 13 20:42:18 CEST 2005

Juri Haberland wrote:
> Pasi Juppo <pasi.juppo at iki.fi> wrote:
>>Juri Haberland wrote:
>>>Pasi Juppo <pasi.juppo at iki.fi> wrote:
>>>>One movie fails to play properly when using TT full featured card, VDR 
>>>>(1.3.22), MPlayer plugin (0.9.11), mplayer (1.0 pre 6 with codes from 
>>>>Feb 2005) and mplayer.sh (0.8.6). Audio stutters constantly.
>>>>However, using following command the audio does not stutter:
>>>>mplayer -vf expand=720:576 -vo mpegpes -ao mpegpes <avi-file>
>>>Please set DEBUG=true (see the end of mplayer.sh.conf) and provide the
>>>log entries when playing this file via mplayer.sh.
>>OK. Here's the log of first attempt which always fails to play any video 
> [snip]
>>Apr 10 18:47:11 backup logger: *** DEBUG: Calling getvidxy function to 
>>analyze source video stream ...
>>Apr 10 18:47:12 backup logger: *** DEBUG: OutputFromMPLAYER: ""
>>Apr 10 18:47:12 backup logger: *** DEBUG: MPLAYER_RETURN:  "1"
>>Apr 10 18:47:12 backup logger: *** FATAL: something went wrong analyzing 
>>the video; mplayer reported an error!
>>Apr 10 18:47:12 backup logger: *** FATAL: check your mplayer 
>>installation. Exiting...
> Do mean to say that this happens on every first attempt to play a
> specific file? If so, this is highly unusual. Where are those video
> files located (e.g. on an NFS or SMb share? How is it mounted? On boot
> or per automounter)?
> Please try to run
>   'mplayer -identify vo null -ao null -frames 0 /your/video.avi'
> and post the error message.

Video files are located on server and seen by HTPC via NFS. Mounting is 
done once at boot (haven't configured automount yet).

I tried to copy files to HTPC but the result was exactly the same.

It happens only once after HTPC have been booted up. Any video clip that 
plays fine causes MPlayer to 'crash' at the first attempt. Here's the 
log you requested. There's clearly something wrong.

MPlayer 1.0pre6-3.3.3 (C) 2000-2004 MPlayer Team
CPU: Intel Pentium 4/Xeon/Celeron Foster (Family: 8, Stepping: 9)
Detected cache-line size is 64 bytes
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2

Setting up LIRC support...
mplayer: could not open config files /root/.lircrc and /etc/lircrc
mplayer: No such file or directory
Failed to read LIRC config file ~/.lircrc.
You will not be able to use your remote control.
Playing vo.
File not found: 'vo'
Failed to open vo

Playing null.
File not found: 'null'
Failed to open null

Cache fill: 12.50% (1048576 bytes)    AVI file format detected.
Detected NON-INTERLEAVED AVI file format.
VIDEO:  [XVID]  640x352  24bpp  23.976 fps  997.0 kbps (121.7 kbyte/s)
SUB: Detected subtitle file format: microdvd
SUB: Read 958 subtitles.
SUB: Adjusted 1 subtitle(s).
SUB: added subtitle file (1): ./<movie_file.sub>
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 48000 Hz, 2 ch, 16 bit (0x10), ratio: 12000->192000 (96.0 kbit)
Selected audio codec: [mp3] afm:mp3lib (mp3lib MPEG layer-2, layer-3)
vo: X11 running at 1280x1024 with depth 24 and 32 bpp (":10.0" => remote 
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffodivx] vfm:ffmpeg (FFmpeg MPEG-4)
Checking audio filter chain for 48000Hz/2ch/16bit -> 48000Hz/2ch/16bit...
AF_pre: af format: 2 bps, 2 ch, 48000 hz, little endian signed int
AF_pre: 48000Hz 2ch Signed 16-bit (Little-Endian)
AO: [oss] 48000Hz 2ch Signed 16-bit (Little-Endian) (2 bps)
Building audio filter chain for 48000Hz/2ch/16bit -> 48000Hz/2ch/16bit...
Starting playback...
VDec: vo config request - 640 x 352 (preferred csp: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.82:1 - prescaling to correct movie aspect.
VO: [xv] 640x352 => 640x352 Planar YV12
Shared memory not supported
Reverting to normal Xv
Shared memory not supported
Reverting to normal Xv
X11 error: BadAlloc (insufficient resources for operation)?,?% 1 0 2%

MPlayer interrupted by signal 6 in module: vo_check_events
- MPlayer crashed. This shouldn't happen.
   It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
   gcc version. If you think it's MPlayer's fault, please read
   DOCS/HTML/en/bugreports.html and follow the instructions there. We 
can't and
   won't help unless you provide this information when reporting a 
possible bug.

Tried again the same command and result was exactly the same so luckily 
the problem seems to be repeatable.

>>And the log of next attempt, which plays fine except for stuttering:
> [snip]
>>Apr 10 18:47:32 backup logger: *** DEBUG: Variable CMDLINE has value 
>>"/usr/local/bin/mplayer -vo mpegpes -ao mpegpes -vop 
>>lavc=5000:25,expand=688:576:-1:-1:1,scale=688:563 -speed 1.04  -cache 
>>8192 -slave -nolirc  -subpos 80 -sub-bg-color 0 -sub-bg-alpha 255 -quiet "
>>Maybe the reason for stuttering comes from the speed parameter?
> Possibly. Try to set USE_SPEED="false" and see if that helps. If so,
> please report back.

Unfortunately it did not solve the problem (the speed parameter was not 
used anymore). I tried it earlier too. Here's the command line:

Apr 13 21:22:01 backup logger: *** DEBUG: Variable CMDLINE has value 
"/usr/local/bin/mplayer -vo mpegpes -ao mpegpes -vop 
lavc=5000:25,expand=688:576:-1:-1:1,scale=688:563   -cache 8192 -slave 
-nolirc  -subpos 80 -sub-bg-color 0 -sub-bg-alpha 255 -quiet "

I tried playing the movie clip from local harddisk but the result was 
exactly the same i.e. network 'slowness' is not the case (100Mbit/s 

Br, Pasi

More information about the vdr mailing list