[vdr] XviD movie stuttering (Mplayer)

Juri Haberland list-linux.vdr at koschikode.com
Sat Apr 16 19:28:17 CEST 2005

Hi and sorry for the late reply.

Pasi Juppo <pasi.juppo at iki.fi> wrote:
> Juri Haberland wrote:
>> Pasi Juppo <pasi.juppo at iki.fi> wrote:
>>>Juri Haberland wrote:
>>>>Pasi Juppo <pasi.juppo at iki.fi> wrote:
>>>>>One movie fails to play properly when using TT full featured card, VDR 
>>>>>(1.3.22), MPlayer plugin (0.9.11), mplayer (1.0 pre 6 with codes from 
>>>>>Feb 2005) and mplayer.sh (0.8.6). Audio stutters constantly.
>>>>>However, using following command the audio does not stutter:
>>>>>mplayer -vf expand=720:576 -vo mpegpes -ao mpegpes <avi-file>
>>>>Please set DEBUG=true (see the end of mplayer.sh.conf) and provide the
>>>>log entries when playing this file via mplayer.sh.
>>>OK. Here's the log of first attempt which always fails to play any video 
>> [snip]
>>>Apr 10 18:47:11 backup logger: *** DEBUG: Calling getvidxy function to 
>>>analyze source video stream ...
>>>Apr 10 18:47:12 backup logger: *** DEBUG: OutputFromMPLAYER: ""
>>>Apr 10 18:47:12 backup logger: *** DEBUG: MPLAYER_RETURN:  "1"
>>>Apr 10 18:47:12 backup logger: *** FATAL: something went wrong analyzing 
>>>the video; mplayer reported an error!
>>>Apr 10 18:47:12 backup logger: *** FATAL: check your mplayer 
>>>installation. Exiting...
>> Do mean to say that this happens on every first attempt to play a
>> specific file? If so, this is highly unusual. Where are those video
>> files located (e.g. on an NFS or SMb share? How is it mounted? On boot
>> or per automounter)?
>> Please try to run
>>   'mplayer -identify vo null -ao null -frames 0 /your/video.avi'
>> and post the error message.


> Tried again the same command and result was exactly the same so luckily 
> the problem seems to be repeatable.

Sorry my fault - I forgot a dash (-) in the aboce command. Please retry
    'mplayer -identify -vo null -ao null -frames 0 /your/video.avi'

>> Possibly. Try to set USE_SPEED="false" and see if that helps. If so,
>> please report back.
> Unfortunately it did not solve the problem (the speed parameter was not 
> used anymore). I tried it earlier too. Here's the command line:
> Apr 13 21:22:01 backup logger: *** DEBUG: Variable CMDLINE has value 
> "/usr/local/bin/mplayer -vo mpegpes -ao mpegpes -vop 
> lavc=5000:25,expand=688:576:-1:-1:1,scale=688:563   -cache 8192 -slave 
> -nolirc  -subpos 80 -sub-bg-color 0 -sub-bg-alpha 255 -quiet "

Hmm, perhaps your CPU isn't fast enough. What kind of CPU do you use
and at what frequency does it run?


More information about the vdr mailing list