[vdr] Centralized 'thread active' handling
Klaus.Schmidinger at cadsoft.de
Sat Aug 13 16:46:12 CEST 2005
Luca Olivetti wrote:
> Stefan Huelswitt wrote:
>> Wouldn't it be better to leave Active() untouched (instead of
>> renaming to Running()) and create a new (differently named)
>> function for the active var replacement? (e.g. Continue(), which
>> would give good readability with while(Continue()))
> In that case I'd suggest Terminated()
> it would somewhat reduce my confusion when switching from the elegance
> of delphi/lazarus to the awkwardness of C++ ;-)
Why use an extra negation here?
I think a positive check ('Active()') is more straightforward
than a negative one ('!Terminated()').
Just wondering: what does this have to do with "elegance" vs. "awkwardness"?
More information about the vdr