[vdr] Centralized 'thread active' handling

Klaus Schmidinger Klaus.Schmidinger at cadsoft.de
Sat Aug 13 17:09:15 CEST 2005

Stefan Huelswitt wrote:
> On 13 Aug 2005 Klaus Schmidinger <Klaus.Schmidinger at cadsoft.de> wrote:
>>Stefan Huelswitt wrote:
>>>Wouldn't it be better to leave Active() untouched (instead of
>>>renaming to Running()) and create a new (differently named)
>>>function for the active var replacement? (e.g. Continue(), which
>>>would give good readability with while(Continue()))
>>Well, Active() reflects the internal 'active' variable, so
>>Continue() would have to correspond to 'continue', which is
>>a reserved keyword...
> This is after your change, but before Active() didn't reflected
> any internal variable. I don't know if one must build such a
> strict rule ...

Of course you don't have to, but it's nice ;-)


More information about the vdr mailing list