[vdr] 1.3.27 with NPTL: (wapd) always crashes at shutdown

Ville Skyttä ville.skytta at iki.fi
Mon Jun 20 08:19:41 CEST 2005

On Sun, 2005-06-19 at 19:49 +0200, Ludwig Nussel wrote:
> Ville Skyttä wrote:
> > 1.3.27 doesn't seem quite NPTL ready, it always crashes at shutdown here
> > on Fedora Core 4 (IIRC also on FC3 and 1.3.2x the last time I tried).
> > No such problems when setting LD_ASSUME_KERNEL=2.4.1.  The backtrace I'm
> > able to obtain looks pretty much useless, but always practically the
> > [...]
> > This is a pretty much patched VDR with lots of plugins, neither of which
> > I can really disable.  Perhaps someone with a more vanilla setup can
> > reproduce?
> Broken plugins can cause such crashes at shutdown. Only enable one
> at a time to find out which one(s).

Ok, it's wapd.

The culprit seems to be cWapServer::Action() in server.c, which I tried
to convert to use cCondWait::SleepMs() instead of usleep(), and added an
"active" boolean into the class that would control the while loop in
Action() and that would be set to false in the destructor, but those
changes did not help.

More ideas?

More information about the vdr mailing list