[vdr] vdr with nexus-s rev 2.1 crashes with ttxtsubs and osdteletext when zapping

Magnus Andersson maan at svankan2.mine.nu
Thu Jun 30 23:26:14 CEST 2005


When I switch from an encrypted channel from my DVB-S (Nexus-S rev. 2.1)
to DVB-T Airstar2 vdr crashes almost every time but if I go from a free to
air channel it is no problem. If vdr does not crash it goes to the first
channel in channel.conf.

The channel I choose shows up and freezes for a short while (less than a
second) after about a second and then it goes on for another 10 seconds as
it should and then it dies or goes to the first channel.

softcam 0: switched to FTA
softcam 0: setting new SID 1090, source c000, transponder 1da

DVB-T to DVB-S always works.

There is no problem with this if I use vdr-xine plugin instead. NO other

I tried to remove plugins and saw that if I removed osdteletext and
ttxtsubs the problem is gone. My family needs subtitle for moviechannels
and animal planet, discovey. I really want to use my FF card instead of
using softdevice because it is easier for me to use the computer while the
other watch tv.

I am almost ready to give up and I have tried vdr 1.3.18-27 and 3
different hotplug firmwares under gentoo linux and kernel 2.6.10-12.

Today I learned a new thing and if I start a recording on an encrypted
DVB-S channel before switching to a DVB-T channel it worked. :)

Both osdteletext and ttxtsubs uses teletext PID in some way I supose. Is
this the problem together with FF card?

Please help!!


More information about the vdr mailing list