[vdr] Can't start VDR via Bash Script with Softdevice Plugin? (SOLVED)

Chad Flynt hoochster at sofnet.com
Wed Nov 30 02:58:56 CET 2005

Well dunno why, but had to run VDR in DAEMON mode in order to run in a 
script.  It runs fine without that mode if you just run it command line, 
but in order to run as a script you run in daemon mode or just end the 
script with an &.  So either way solved my issue.!  For anyone else that 
might encounter it!

Chad Flynt wrote:

> Hi, I am starting to play with the SoftDevice Plugin, and trying to 
> start VDR via a BASH script.  All appears to start but it never 
> completes, and I don't get any output, and have no ability to Telnet 
> in to VDR.  If I start via straight Command Line it works fine.  Is 
> there something I am missing?  Here is how I have a script setup.
> #!/bin/sh
> cd /usr/local/bin
> ./vdr -P"softdevice -vo dfb: -ao alsa:pcm=default"
> That is just an example but it is the jist of it.  Script is 
> executable, and I run it with root priveledges.  VDR does appear to 
> start up and I get scrolling text etc, but I get no video, nor can I 
> telnet in on port 2001 to control it.  BUT, if I just run the ./vdr 
> script above with those options from command line it runs just fine.  
> And if I run VDR in a bash script with any other plugin and take out 
> the Softdevice plugin it works fine.  Just trying to troubleshoot 
> where I might have something wrong.
> Thanks for any help.
> _______________________________________________
> vdr mailing list
> vdr at linuxtv.org
> http://www.linuxtv.org/cgi-bin/mailman/listinfo/vdr

More information about the vdr mailing list