AW: [vdr] VDSB with Kernel 2.6.13 at
Tue Sep 20 19:33:36 CEST 2005

vdr-bounces at wrote:

> I got something I desperately need help with:
> I have got one FF card plus 3 Nova CI Budget Cards, usually using the
> latest driver, firmware and VDR versions. 
> After having upgraded to Kernel 2.6.13, I get the dreaded "Video Data
> Stream Broken" error as soon as a recording starts. 
> Vanilla VDR 1.3.32 (no plugins besides remote) with
> reports "no dvb card available for recording" instead:
> Sep 20 17:40:44 [vdr] timer 5 (1 1740-2040 '@TITLE EPISODE') start
> Sep 20 17:40:44 [vdr] record
> /video0/@Brisant_Boulevardmagazin/2005-09- Sep 20
> 17:40:49 [vdr] ERROR: device 2 has no lock, can't attach receiver!  
> Sep 20 17:40:49 [vdr] ERROR: Keine freie DVB-Karte zum Aufnehmen!
> The log reports 4 video devices found.
> When switching back to 2.6.12 everything works fine again (same
> driver, same firmware) problem recording from 4 different
> transponders...  
> Of course I also tried the latest (yesterday's) CVS driver and the
> latest Firmware (fb2620). 

Same to me (but 2xFF 2.1 + 1x Nova-s). I ended with putting out the budget
card and run the system with 2xFF cards only. My observation was that if the
PC was just booted the budget card worked (NVRAM-Wakeup) but when there are
several recordings going on and the budget was used later (e.g. uptime 1h)
vdr reported no lock. I tried several kernels and different cvs versions of
the dvb-drivers and different firmwares but no go.
>> From looking at dmesg I can tell the cards' IRQ assignments have
>> changed,
> but still each card uses its own one.
> Also, they still share their IRQs with the very same other PCI
> devices. 
> szap seems to be able to tune, though, as it reports FE_HAS_LOCK on
> all 4 cards when tuning to "Das Erste". 
> Any hints on how to debug this further?

Might be a powerconsumption problem, are you sure the power supply is strong
enough to serve all your cards ?

> Thanks,
> Stephan


More information about the vdr mailing list