[vdr] cChannel::Nid() should be renamed to cChannel::Onid()

Klaus Schmidinger Klaus.Schmidinger at cadsoft.de
Fri Feb 10 13:55:04 CET 2006

Patrick Fischer wrote:
> The Function cChannel::Nid() returns the OridignalNetworkID and not the 
> NetworkID, so it is a little bit confusing.
> This are two differents Values.
> So the cChannel::Nid() should return the NetworkID and cChannel::Onid() 
> should return the OriginalNetworkID.
> I know vdr will not use this values, but I do.

I was sometimes wondering what the difference between the two is.
Can you enlighten me?


More information about the vdr mailing list