[vdr] Re: cChannel::Nid() should be renamed to cChannel::Onid()

Marcel Wiesweg marcel.wiesweg at gmx.de
Sun Feb 12 18:06:51 CET 2006

Am Freitag 10 Februar 2006 13:55 schrieb Klaus Schmidinger:
> Patrick Fischer wrote:
> > The Function cChannel::Nid() returns the OridignalNetworkID and not the
> > NetworkID, so it is a little bit confusing.
> > This are two differents Values.
> > So the cChannel::Nid() should return the NetworkID and cChannel::Onid()
> > should return the OriginalNetworkID.
> > I know vdr will not use this values, but I do.
> I was sometimes wondering what the difference between the two is.
> Can you enlighten me?

To identify a transport stream (onid-tid), a service (onid-tid-sid or 
onid-sid) or an event, you have to use the onid. As I understand it,  the 
idea is that the onid identification is (in theory) independent from the 
physical network which is identified by the nid.
When you have a look at 
there a two lists, for nid and onid, although many values are identical.
I think in practice you almost always use the onid.


More information about the vdr mailing list