[vdr] Re: cChannel::Nid() should be renamed to cChannel::Onid()

Patrick Fischer patrick_fischer at gmx.de
Sun Feb 12 19:46:11 CET 2006

That would be ok.
There are 6 Plugins how use the Nid(), so maybe there is no big problem 
to rename it to Onid() but a mark whould be ok two.


Klaus Schmidinger schrieb:

> Marcel Wiesweg wrote:
>> Am Freitag 10 Februar 2006 13:55 schrieb Klaus Schmidinger:
>>> Patrick Fischer wrote:
>>>> The Function cChannel::Nid() returns the OridignalNetworkID and not 
>>>> the
>>>> NetworkID, so it is a little bit confusing.
>>>> This are two differents Values.
>>>> So the cChannel::Nid() should return the NetworkID and 
>>>> cChannel::Onid()
>>>> should return the OriginalNetworkID.
>>>> I know vdr will not use this values, but I do.
>>> I was sometimes wondering what the difference between the two is.
>>> Can you enlighten me?
>> To identify a transport stream (onid-tid), a service (onid-tid-sid or 
>> onid-sid) or an event, you have to use the onid. As I understand it,  
>> the idea is that the onid identification is (in theory) independent 
>> from the physical network which is identified by the nid.
>> When you have a look at 
>> http://www.dvb.org/products_registration/dvb_identifiers/
>> there a two lists, for nid and onid, although many values are identical.
>> I think in practice you almost always use the onid.
>> Marcel
> So it would appear that the "networkId" is pretty useless to VDR.
> Since VDR only needs one value to identify the "network", and won't
> even look at the other one, I'd like to leave it as it is now, so
> it's "Network/Transponder/Service". I'd go as far as adding a comment
> to channels.h, though, that says
> struct tChannelID {
> private:
>   int source;
>   int nid; // actually the "original" network id
>   int tid;
>   int sid;
>   int rid;
> Klaus
> _______________________________________________
> vdr mailing list
> vdr at linuxtv.org
> http://www.linuxtv.org/cgi-bin/mailman/listinfo/vdr

More information about the vdr mailing list