[vdr] Streamdev HTTP attach not grabbing a free DVB card?

Niko Mikkila nm at phnet.fi
Tue Feb 21 10:06:54 CET 2006

On Mon, 20 Feb 2006 23:03:27 +0200
"Jukka Vaisanen" <Jukka.Vaisanen at exomi.com> wrote:

> I recently moved on to the wonderful world of multiple DVB-T cards in my
> VDR and also set up streamdev-server for use with VLC for
> HTTP/PES-streams to a remote PC. However I ran into a problem with how
> streamdev and my primary output coexist.
> Software:
> -          vdr-1.3.43
> -          DVB drivers from 2.6.15-gentoo-r1 kernel
> -          dxr3-0.2.5 plugin
> -          Latest streamdev-cvs (Jan 20)
> Hardware:
> -          2x Airstar2 budget DVB-T (FlexCopIIb)
> -          DXR3 (Hollywood+)
> -          P3/800 + 1.5GB RAM
> And how / what happens:
> - I restart VDR "fresh" with only dxr3 and streamdev plugin loaded
> - I switch my primary output (dxr3) to the preferred channel, works fine
> - I connect via the streamdev HTTP server to a channel which is on
> another mux and my dxr3 output switches to the first channel in that
> mux. Apparently the streamdev is somehow grabbing the same budget card
> and forcing the mux switch.

I recall something like this when I first tried streamdev with a VDR
client. I "fixed" the problem by forcing each DVB card to a specific
mux in channels.conf. Somehow I thought this wasn't a problem with HTTP
streaming, but that doesn't make sense, so I probably remember it wrong.
I've also kept the forced settings for other reasons, which keeps me
from experiencing these annoying switches.


More information about the vdr mailing list