[vdr] xine plugin

Reinhard Nissl rnissl at gmx.de
Thu Jan 26 22:21:39 CET 2006


Chad Flynt wrote:

> I tried compiling Xine last night albeit was the CVS from yesterday, so 
> maybe I need to grab the one from the 5th, but applied these patches and 
> when I compile it and try to do the install I get the following:  This 
> is for XINE-LIB
> make  install-data-hook
> make[4]: Entering directory 
> `/usr/local/src/xine.cvs/xine-lib/src/xine-engine'
> chcon system_u:object_r:texrel_shlib_t /usr/lib/libxine.so
> chcon: /usr/lib/libxine.so: Operation not supported
> make[4]: *** [install-data-hook] Error 1
> make[4]: Leaving directory 

I've read about this issue on xine devel ML and I thought this should be 
fixed, but obviously this is not the case.

As a workaround, just locate the following line below 
"install-data-hook:" in misc/Makefile.common:

         if test -x /usr/bin/chcon -a `id -u` -eq 0; then \

and change it for example to:
         if false; then \

I had the same problem on my system and "solved" it temporarily by 
disabling the offending code.

Dipl.-Inform. (FH) Reinhard Nissl
mailto:rnissl at gmx.de

More information about the vdr mailing list