[vdr] Burn plugin permissions problem

Stuart Morris stuart_morris at talk21.com
Fri Sep 1 10:27:15 CEST 2006

The script vdrburn-dvd.sh starts with #!/bin/sh
I tried changing it to #!/bin/bash but I got the same result.
I also tried changing the default interpreter from sh to
bash for the vdr user but again with the same result.

The script vdrburn-dvd.sh already has the command set -x
which I guess enables logging.

Could this be a problem with mjpegtools1.6.2 and not the script?


Marko Mäkelä <marko.makela at hut.fi> wrote: On Wed, Aug 30, 2006 at 09:37:42AM +0100, Stuart Morris wrote:
> I can create DVD ISO files using vdr-burn-0.1.0-pre20 ok but only if vdr is run as root.
>  If I run vdr without root privelage DVD ISO creation fails at the start.
>  My /tmp folder and ISO destination folder have the appropriate access rights.
>  The burn shell scripts are marked executable and can be read by others.
>  Any one know what is wrong here?
>  Here is the dvd.log file
> [render] sh: /usr/local/bin/vdrburn-dvd.sh: Permission denied

First of all, does the script start with a proper #! line pointing
to a valid interpreter that can be run by the vdr user, e.g., #!/bin/sh?

If there is a permission problem within the script commands, you can
track it down by adding the parameter -x to the #!/bin/sh or #!/bin/bash
line.  That enables the logging of the commands executed by the shell
script.  Then you should be able to see which command fails and try to
run that command as the vdr user from the shell prompt, optionally
under strace to find out what is causing the permission problem.


vdr mailing list
vdr at linuxtv.org

 Send instant messages to your online friends http://uk.messenger.yahoo.com 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.linuxtv.org/pipermail/vdr/attachments/20060901/46118ae2/attachment.htm

More information about the vdr mailing list