[vdr] libmad compile issue with mplayer plugins 0.9.15pre14 / VDR 1.4.2

Philippe Gramoullé philippe at gramoulle.com
Wed Sep 6 22:40:57 CEST 2006


I'm currently trying to upgrade from vdr-1.3.47 & plugins to 1.4.2(with latest fixes) & plugins.

The VDR part is ok, it builds and runs fine.

The plugin i use the most is mplayer.

I tried to install the latest version 0.9.15pre14 for VDR 1.4.0+

I have the following error (i tried with older mp3 plugins versions as well)

/usr/src/vdr-1.4.2# make plugins
Plugin mp3:
make[1]: Entering directory `/usr/src/vdr-1.4.2/PLUGINS/src/mp3-0.9.15pre14'
g++ -march=pentium3 -O3 -c -D_GNU_SOURCE -DAPIVERSNUM=10402 -DHAVE_SNDFILE -DHAVE_VORBISFILE -I../../../include mp3.c
/usr/include/mad.h:552: error: expected unqualified-id before 'unsigned'
/usr/include/mad.h:552: error: abstract declarator 'const unsigned char*' used as declaration
/usr/include/mad.h:552: error: expected ';' before 'unsigned'
make[1]: *** [mp3.o] Error 1
make[1]: Leaving directory `/usr/src/vdr-1.4.2/PLUGINS/src/mp3-0.9.15pre14'

Any idea ?

I'm using gcc/g++ 4.1 ( Debian x86 unstable with latest packages)



More information about the vdr mailing list