[vdr] libmad compile issue with mplayer plugins 0.9.15pre14 / VDR 1.4.2

Stefan Huelswitt s.huelswitt at gmx.de
Thu Sep 7 23:03:25 CEST 2006

On 06 Sep 2006 Philippe =?ISO-8859-15?Q?Gramoull=E9?= <philippe at gramoulle.com> wrote:

> I tried to install the latest version 0.9.15pre14 for VDR 1.4.0+
> I have the following error (i tried with older mp3 plugins versions as well)
> /usr/src/vdr-1.4.2# make plugins
> [snap]
> Plugin mp3:
> make[1]: Entering directory `/usr/src/vdr-1.4.2/PLUGINS/src/mp3-0.9.15pre14'
> g++ -march=pentium3 -O3 -c -D_GNU_SOURCE -DAPIVERSNUM=10402 -DHAVE_SNDFILE -DHAVE_VORBISFILE -I../../../include mp3.c
> /usr/include/mad.h:552: error: expected unqualified-id before 'unsigned'
> /usr/include/mad.h:552: error: abstract declarator 'const unsigned char*' used as declaration
> /usr/include/mad.h:552: error: expected ';' before 'unsigned'
> make[1]: *** [mp3.o] Error 1
> make[1]: Leaving directory `/usr/src/vdr-1.4.2/PLUGINS/src/mp3-0.9.15pre14'
> Any idea ?
> I'm using gcc/g++ 4.1 ( Debian x86 unstable with latest packages)

I'm sorry, but probably this is a compatibility problem between
libmad and your gcc version (taking that's the same error with
all mp3 plugin versions).

If you're not using latest libmad, I would try to upgrade that

If you only want the mplayer plugin and you don't need the mp3
plugin, you can disable compile of the mp3 part in the plugin
Remove the comment mark in front of WITHOUT_MP3=1


Stefan Huelswitt
s.huelswitt at gmx.de  | http://www.muempf.de/

More information about the vdr mailing list