[vdr] subtitles-0.5.0 and gentoo

Ville Aakko ville.aakko at gmail.com
Sat Jun 30 10:31:20 CEST 2007


AFAIK vdr 1.4.7 doesn't fix the error with subtitles not being
recorded (well, at least it's not in the changelog; OTOH I've
understod that the problem lies in the plugin, but then again I tried
vdr-subtitles 0.5.0 with vdr 1.4.6, and it had no effect). VDR 1.5.5
works fine for me in this aspect, at least for now (haven't tested it
thoroughly yet though since I installed it only two days ago).

However, VDR 1.5.5 ebuilds in the overlay have a few problems (which
is understandable since they are developing versions of the ebuilds).
But, since recording subtitles is such a core feature for me (and
probably for a lot of other people, too), I found it worthwhile to get
1.5.5 running. Here are the problems I needed to work around
(hopefully I didn't forget anything):

(I need text2skin, since I'm using DXR3 and no other skins are stable
enough on DXR3. Also, on vdr 1.5.X, the default skin is totally
garbled and unusable on a dxr3.). I needed to add the patch from this
mailing list thread "updated text2skin for vdr-1.5.3 and enigma?" to
the ebuild. Then it compiled and seems to work fine.

The current version does not compile against 1.5.X. There is
0.9.23_beta1 ebuild in vdr-1.5 overlay, however that is outdated,
since the current beta is beta3, and the beta1 source is not anymore
on the epgsearch site. Just copying the ebuld to beta3 (and doing
'ebuild X digest') solved that one - and probaly the ebuild will be
renamed on the overlay soon, too =).
Don't now if this beta has some nasty bugs, but at least the blue
smoke is still inside my VDR =)

gentoo-vdr-scripts, locales, UTF-8 and Scandinavian characters (umlauts):
After getting VDR 1.5.5 working, one quite annoying problem was left:
all non-7-bit characters were displayed as ?-marks, if using
gentoo-vdr-scrips (which I'm quite dependant for the functionality
they provide, but unfortunately made for <1.5.0 in mind). I found that
in /usr/share/vdr/rcscripts/pre-start-45-utf8-check.sh all locales are
reset to POSIX; however, this makes VDR 1.5.5 misbehave. I modified
the script so that LC_ALL and LANG are set to fi_FI.UTF-8, and now
everything works like a charm.

subtitles: I needed to copy subtitles-0.4.0 to my local overlay as
0.5.0. But since it's officially in the Gentoo now, you shouldn't need
to do this anymore.

One minor problem still remains, and that is with lcdproc: It expects
characters in iso-8859-15, judging from what I can see on my LCD. But
I can live with that. Also, the iMon driver for lcdproc or the LIRC
modules are unstable for some reason on my box, anyways - the LCD just
hangs after 1-x hours of viewing. But that's another issue. (btw. I
have an Antec Fusion case, along with the VFD and the volume knob it
came with).

Also, all recordings done previously have the scandinavian characters
displayed as ?-marks (in the info screen, don't have any DVB subtitles
in the old recordings to test with 'cause of this bug). This is also a
very minor problem IMO. Maybe fixable by running enca, if the files
containing the info's are in ASCII. Haven't looked into this since it
doesn't bother me.

Yep, these are really ugly fixes, for the most part. But just thought
worth to mention, since I do think a lot of people really need those
subtitles in recordings.

Finally, here's a list of plugins I'm using and find working in 1.5.5,
for reference:


- Ville

2007/6/29, Joerg Bornkessel <ml at websitec.de>:
> Guten Tag JJussi,
> am Freitag, 29. Juni 2007 um 17:15 schrieben Sie:
> > Hi!
> > I have problem with YLE and subtitles. Subtitles work on "live", but can't see
> > them when watching recording..
> > OK, If I have understand right the information what I found from net, that
> > should be fixed at subtitles-0.5.0..
> > So.. I use gentoo and it's packeting system. How I can include this 0.5.0
> > version to my system, gentoo have only 0.4.0 version on it's repository.. Who
> > is upkeeping vdr stuff at gentoo side... (OK, that "who" should insert
> > vdr-1.4.7 too)
> Who?
> Yust zzam and me support the VDR and all the crap around this ;)
> Sry for missing the "versions bump", a friendly reminder on
> https://bugs.gentoo.org/
> should help for this very fast.
> btw. i am added the vdr-subtiltles-0.5.0 10 minutes ago to the
> CVS tree.
> Give the rsync server a half hour to sync from CVS, than
> can you emerge vdr-subtitles.
> To update the VDR to 1.4.7 maybe this bug will be interresting for
> you.
> https://bugs.gentoo.org/show_bug.cgi?id=183441
> You can also update to developer version vdr-1.5.x
> emerge layman
> layman -a vdr-1.5
> but dont slay us with bugs, this is the developer version !
> We work on this 24/7 ;)
> --
> Regards
> Gentoo Developer
> Joerg Bornkessel <hd_brummy at gentoo.org>
> _______________________________________________
> vdr mailing list
> vdr at linuxtv.org
> http://www.linuxtv.org/cgi-bin/mailman/listinfo/vdr

Ville Aakko - ville.aakko at gmail.com

More information about the vdr mailing list