[vdr] subtitles-0.5.0 and gentoo

Matthias Schwarzott zzam at gentoo.org
Sat Jun 30 20:39:00 CEST 2007

On Samstag, 30. Juni 2007, you wrote:
> Hi,
Hi Ville!

Nice to hear there are actually users of the ebuilds ;)

> AFAIK vdr 1.4.7 doesn't fix the error with subtitles not being
> recorded (well, at least it's not in the changelog; OTOH I've
> understod that the problem lies in the plugin, but then again I tried
> vdr-subtitles 0.5.0 with vdr 1.4.6, and it had no effect). VDR 1.5.5
> works fine for me in this aspect, at least for now (haven't tested it
> thoroughly yet though since I installed it only two days ago).
> However, VDR 1.5.5 ebuilds in the overlay have a few problems (which
> is understandable since they are developing versions of the ebuilds).
> But, since recording subtitles is such a core feature for me (and
> probably for a lot of other people, too), I found it worthwhile to get
> 1.5.5 running. Here are the problems I needed to work around
> (hopefully I didn't forget anything):
Well, we hope to get the most annyoing problems out of the ebuilds soon.

> text2skin:
> (I need text2skin, since I'm using DXR3 and no other skins are stable
> enough on DXR3. Also, on vdr 1.5.X, the default skin is totally
> garbled and unusable on a dxr3.). I needed to add the patch from this
> mailing list thread "updated text2skin for vdr-1.5.3 and enigma?" to
> the ebuild. Then it compiled and seems to work fine.
I dont use it and have no real idea how it works.
If you have a patch to make it working, just send it to me and I will add that 
to the ebuild.

> epgsearch:
> The current version does not compile against 1.5.X. There is
> 0.9.23_beta1 ebuild in vdr-1.5 overlay, however that is outdated,
> since the current beta is beta3, and the beta1 source is not anymore
> on the epgsearch site. Just copying the ebuld to beta3 (and doing
> 'ebuild X digest') solved that one - and probaly the ebuild will be
> renamed on the overlay soon, too =).

Done that!

> Don't now if this beta has some nasty bugs, but at least the blue
> smoke is still inside my VDR =)
> gentoo-vdr-scripts, locales, UTF-8 and Scandinavian characters (umlauts):
> After getting VDR 1.5.5 working, one quite annoying problem was left:
> all non-7-bit characters were displayed as ?-marks, if using
> gentoo-vdr-scrips (which I'm quite dependant for the functionality
> they provide, but unfortunately made for <1.5.0 in mind). I found that
> in /usr/share/vdr/rcscripts/pre-start-45-utf8-check.sh all locales are
> reset to POSIX; however, this makes VDR 1.5.5 misbehave. I modified
> the script so that LC_ALL and LANG are set to fi_FI.UTF-8, and now
> everything works like a charm.

Well, we are still in discussion phase how gentoo-vdr-scripts should behave.
Attached is some code we think could be almost ready for commiting to 
The conf-changes is just to comment that one can set LANG inside conf.d/vdr, 
and need not have it system-wide.

> Also, all recordings done previously have the scandinavian characters
> displayed as ?-marks (in the info screen, don't have any DVB subtitles
> in the old recordings to test with 'cause of this bug). This is also a
> very minor problem IMO. Maybe fixable by running enca, if the files
> containing the info's are in ASCII. Haven't looked into this since it
> doesn't bother me.
You mean filename or content of info.vdr. Well both should be solvable. First 
by convmv, second by recode or similar like iconv.

> Yep, these are really ugly fixes, for the most part. But just thought
> worth to mention, since I do think a lot of people really need those
> subtitles in recordings.
> Finally, here's a list of plugins I'm using and find working in 1.5.5,
> for reference:
> dxr3
> femon
> osdteletext
> epgsearch
> mplayer
> undelete
> streamdev-server
> text2skin
> lcdproc
> subtitles
> control
> externalplayer
If you still have patches not yet inside the ebuilds we are happy to apply 


Matthias Schwarzott (zzam)
-------------- next part --------------
A non-text attachment was scrubbed...
Name: pre-start-45-utf8-check.sh
Type: application/x-shellscript
Size: 1530 bytes
Desc: not available
Url : http://www.linuxtv.org/pipermail/vdr/attachments/20070630/a0d56ef5/attachment.bin 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: conf-changes.diff
Type: text/x-diff
Size: 945 bytes
Desc: not available
Url : http://www.linuxtv.org/pipermail/vdr/attachments/20070630/a0d56ef5/attachment.diff 

More information about the vdr mailing list