[vdr] xineliboutput not working

hudo kkow 2manybills at gmail.com
Wed Nov 5 01:30:50 CET 2008

On Tue, Nov 4, 2008 at 11:34 PM, Mika Laitio <lamikr at pilppa.org> wrote:
>>> On Sunday 02 November 2008 12:46:16 Artem Makhutov wrote:
>>>> Hi,
>>>> On Sat, Nov 01, 2008 at 05:48:07PM +0100, horchi wrote:
>>>>> Hi,
>>>>> i like to use the actual vdr 1.7.1 with the xineliboutput plugin. I don't
>>>>> need h264 or any HDTV this time.
>>>>> Has anybody vdr 1.7.1 with xineliboutput running properly?
>>>> No, xineliboutput does not work for me too with 1.7.1. It worked fine
>>>> with 1.7.0.
>>>> Regards, Artem
>> Well, I have vdr 1.7.0 + h264 patch + s2api patch + cvs xineliboutput
>> + hg xine-lib 1.2 + svn ffmpeg + s2 api drivers v4l-dvb and
>> xineliboutput is _NOT_ working fine. It segfaults upon startup. Every
>> time, no matter the parameters I pass during startup.
>> Even vdr-xine experinces the same problems (jittered image but sound
>> ok) but no segfaults on startup. Only during play live stream :(
>> It seems it has problems with OSD and overlay Xv on ATI 1250 Express
>> but and this a big but :) it also has the same behavior with a Geforce
>> 6600GT that I have laying around.

> Is it happening for you both with S and S2 channels?
> Many people including me have noticed corrupted image problems with
> xineliboutput with commercial ATI drivers. (I tested myself last time
> about 2 months ago)

Yes. It happens on both.

> A workaround was to switch to console ctrl+alt+1 and then back to X with
> ctrl+alt+7.

Never tried that. Just droped ATI Catalyst use.

> To get things really workign without problems I switched to radeonhd
> drivers.

That's what I was testing right now. And it even stopped segfaulting
when you touched any keyboard key.

> I have myself using vdr 1.6.0 as I had problems to get dvb-t channels to
> work with S2API patched vdr-1.7.0 and have only tested S2 from command
> line with a combination of following:
> 1) channels.conf
> arteHD:11361:hC23M5O35S1:S19.2E:22000:6210:6230:0:11120:1:1011:0
> 2) ./szap-s2 -a 1 -S 2 -c channels.conf artehd
> 3) dvbstream -c 1 8192 -o > test3.mpg
> 4) vlc test3.mpg
> Mika

I havent't tried that. I'll give it a shot.

Strangest thing is that I can decode HD channels - even jittered- on
DVB-S but not on DVB-S2 8PSK. These last just don't work in any way
and appear to be dead. Don't know what I'm missing, but that's for
another thread.

I still have segfaults on xineliboutput and can't identify why. AFAIK,
nothing changed except for multiproto >> S2API, and some cvs/hg
compiled software.

Anyhow, RadeonHD drivers seem to be much better than Catalyst.

More information about the vdr mailing list