[vdr] mplayer plugin doesn work when vdr run from inittab

Torgeir Veimo torgeir at pobox.com
Mon Oct 6 15:41:50 CEST 2008

On 6 Oct 2008, at 19:00, André Weidemann wrote:

> Hi,
> Torgeir Veimo wrote:
>> The mplayer plugin doesn't work when I start vdr from inittab. It
>> works ok if vdr is started from the console.
>> I've seen hints that $USER and $HOME need to be set, but setting  
>> these
>> in my startup script doesn't change anything.. Anyone got any idea
>> what's missing?
>> Also, it would be an idea to be able to get the log output from the
>> mplayer plugin somehow.
> This is most likely because the PATH variable is not set. So set the
> PATH variable in your runvdr script and mplayer will be working  
> fine. At
> least it is working here in my machine.

I tried now, with a /etc/rc.vdr containing;

# Start VDR

export HOME="/root"
export USER="root"
export LANG="en_US"
export PATH="/sbin:/usr/sbin:/bin:/usr/bin:/usr/local/bin"

/bin/setserial /dev/ttyS1 uart none;
/sbin/modprobe lirc_serial

/usr/bin/screen -dmS vdr /usr/local/bin/runvdr 2>&1 >| /tmp/vdrlog.txt &

Still doesn't work. rc.vdr is started from /etc/rc.local.

Maybe the problem is the extended runvdr script by Udo Richter I'm  

Torgeir Veimo
torgeir at pobox.com

More information about the vdr mailing list