[vdr] VDR 1.7.0 & S2API - Channels not Available

Morfsta morfsta at gmail.com
Wed Feb 4 10:16:01 CET 2009


Due to an attempt on OS upgrade and thus kernel upgrade I'm grudgingly
(it worked for me for months with no issues so why would I want to
change it for now?) trying to make the transition from multiproto to
S2API. I have two DVB-T cards and a NOVA-S2-HD (HVR4000 lite). I have
downloaded a vanilla vdr-1.7.0 applied the h264 patch and the s2api
patch and install S2API from Steven Toth's mercurial repository.

On booting the kernel loads all the modules and I see the various
frontends and when I start VDR it loads all of the relevant firmware
okay. When I start VDR it won't show any of the FTA channels on DVB-T
or DVB-S (not even tried S2!) and all I get is "Channel Not
Available". I wish VDR were more descriptive in why the channels are
not available! :-)

Apologies if this has been asked before, but is there anything I'm
missing? Is the problem that I took my channels.conf from my
multiproto VDR and something has now changed in the format?

It would be good to get this working as my old OS is now messy and
really needs a clean build with a shiny new kernel and I can't patch
up to date multiproto with the old HVR4000 patches (a few FAILS which
I guess I could fix, but might take some time as they don't look that
trivial) and an older version of multiproto from HG doesn't compile on
the new kernel!

Can anyone point me in the right direction on what might be going on?


More information about the vdr mailing list