[vdr] vdr-iptv-plugin DVB subtitles problems

Fake Name faker1a at yahoo.com
Wed Sep 8 18:38:26 CEST 2010

Hi I cant' display DVB subtitles on VDR.

I'm using:
VDR 1.7.15
xine 0.9.3
source: iptv-plugin 0.4.2 (http://www.saunalahti.fi/rahrenbe/vdr/iptv/)
(yaVDR 0.2)
on Asrock ION 330 HT
DVB Subutitles are enabled under System/Setup/DVB and Language chosen is 
Slovenski (Slovenian-SLV).

The  iptv plugin detects the subtitles pid in question  
(System/Plugins/iptv/Info but no matter what I do, the channel in  question 
returns "No subtitles available"
The plugin passes mpeg2/4 stream directly to VDR and it does it superbly (HDTV 
great, EPG great, Channel switching fast, Stable, Teletext...)

My IPTV (T-2, Slovenia) provider uses udp multicast and I can watch all the 
programs in VLC, with subtitles, ttx... This is the m3u playlist for VLC:
This is the line in VLC playlist for HBO:

This is Codec Information from VLC:
Stream 0
Type: Video
Codec: MPEG-1/2 Video (mpgv)
Resolution: 640x576
Frame rate: 50
Stream 1
Type:  Audio
Original ID: 802
Codec: MPEG Audio layer 1/2/3 (mpga)
Language: slovenščina
Channels: Stereo
Sample rate: 48000 Hz
Bitrate: 192 kb/s
Stream 2
Type: Audio
Original ID: 1204
Codec: A52 Audio (aka AC3) (a52 )
Stream 3
Type: Subtitle
Original ID: 7302
Codec: DVB Subtitles (dvbs)
Language: slovenščina
Description: DVB subtitles

Those  are lines from channels.conf, I started experimenting with HBO and  tried 
a lot of variations(realy alot :). I still think I'm messing  something up wit 
the syntax.





If I record the video with VDR and run dvbsnoop |grep 7302  (subtitles id) I get 
no results (dvbsnoop can't analyze live iptv  streams). I also dumped the stream 
with mplayer and tried playing back  the video, but there were no subtitles 
(record subtitles is checked in  options). But because this is the first time I 
ran dvbsnoop and even  after reading dvbsnoops man pages, I'm not sure if I did 
everything  right. I'm also not very good with mplayer, so i ran with -alang, 
maybe  I'm doing something wrong? 

Another problem is, that if I mess  with DVB update channels (update pid, pid 
and names, names only,  transponder...) I sometimes lock the HBO channel (no a/v 
and OSD "Channel Locked). Also when checking dvbsnoop I noticed some lines with 
CA (i think it stands for Conditional Access)  in them. But recently I can't 
reproduce that behaviour no matter what I  do. But I'm paying for HBO and I can 
watch it in VLC and (most of the  times) in VDR.
Running  iptv-plugin with "EXT" and using VLC in VDR does not work (A/V OK, but  
again no subtitles). Also it seems a bit "crashy", so I would rather get  it 
working this way.

So far I read the man pages for VDR, VDR wiki in english, some pages in german 
and IPTV plugin readme. I searched the net, vdr-portal.de and this mailig list 
for subtitles, untertitel, dvb subtitles problems,  etc, but I could not find 
the answer. I posted this question on  vdr-portal: 
http://www.vdr-portal.de/board/thread.php?threadid=99300 and spent some time in 
the vdr irc channel (thank you again nox), but  no matter what I do, I can't get 
those pesky DVB subtitles to display.
I  tried hts tvheadend, mythtv and even media portal but they are all  flawed in 
one way, or the other. But because VDR is in a league of its  own, I'm bothering 
all of you. VDR has no problems with 1080i/p  channels, fast channel switching 
and even I can't crash it. Also yaVDR  0.2 is realy practical.

Because this is the first time I came  into contact with DVB, IPTV, SID's, 
PID's, etc, I'm probably doing  something wrong and any help is deply 
Some more info:
my setup.conf
one of my channels.conf:

Thanks for reading all of my problems, and I hope someone can help.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.linuxtv.org/pipermail/vdr/attachments/20100908/edfba4d9/attachment.htm>

More information about the vdr mailing list