[vdr] [solved] VDR 1.7.28, xineliboutput 1.0.7: Using local frontend gives `No protocol specified`

Paul Menzel paulepanter at users.sourceforge.net
Fri Jun 15 12:16:23 CEST 2012

Am Freitag, den 15.06.2012, 12:47 +0300 schrieb Petri Hintukainen:
> On ti, 2012-06-12 at 11:31 +0200, Paul Menzel wrote:

> > somehow I am not able to get the local frontend to work.
> > 
> > Debian Sid/unstable is installed with
> > 
> >         $ dpkg -l vdr vdr-plugin-xineliboutput libxineliboutput-sxfe
> >         […]
> >         ii  libxineliboutput-sxfe         1.0.7+cvs20120609.1902-1      Local X-Server frontend for the xineliboutput plugin
> >         ii  vdr                           1.7.28-1                      Video Disk Recorder for DVB cards
> >         ii  vdr-plugin-xineliboutput      1.0.7+cvs20120609.1902-1      VDR plugin for Xine based sofdevice frontends
> > 
> > and I try to get the local frontend working but it fails.
> > 
> >         $ sudo -u vdr vdr -P"xineliboutput --local=sxfe --video=auto --audio=alsa --remote=none"
> >         No protocol specified
> >         No protocol specified
> >         No protocol specified
> Maybe it has no rights to open X window. Do you see any errors in log ?

I did not see any errors printed to the terminal. What log file should I
have looked at?

> Do you start it from X terminal ?

Yes. I used GNOME Terminal with GNOME 3 running.

> Some things to try:
> - run "xhost +si:localuser:vdr" or "xhost +" before starting vdr
>   (note that this opens a security hole)

That indeed helped. Both commands work and knowing the solution it of
course is the vdr user forbidden to put windows on the X session of a
different user.

> - try starting without su
>   (as current user, or with vdr option --user=vdr)

I had tried that before and the problem is that the video directory is
owned by the vdr user and it looks like starting `vdr` from a normal
user and passing `--user=vdr` cannot change the user. That is why I
tried it with `sudo`.


Thanks a million,

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 198 bytes
Desc: This is a digitally signed message part
URL: <http://www.linuxtv.org/pipermail/vdr/attachments/20120615/d0b42493/attachment.pgp>

More information about the vdr mailing list