[vdr] DVB_API_VERSION problem

Dave vdr at pickles.me.uk
Sat Jan 12 14:03:42 CET 2013

On 11/01/13 23:50, Leo Márquez wrote:
> Dear all,
> I'm trying to build vdr-1.7.35.
> I know that it requires at least a DVB driver with api version 5.3 or
> higher. For this reason I downloaded and compiled the V4L-DVB dvb
> drivers from linuxtv.org <http://linuxtv.org>.
> The process seems to be completed ok, I restarted to be sure the new
> driver is used and I also created a Make.config file in the vdr folder
> in order to specify the DVBDIR but VDR is still complaining about the
> At this time I'm a little bit confused and I'm not sure if I'm using the
> new driver or not. Is there a way to check if I'm using a dvb api
> version 5.3 or higher?
> If I check the DVB api version and it is ok, what can I do next?
> I'm using debian squeeze with kernel 2.6.32.
> Thank you very much.

VDR checks the API version by looking in the DVB version.h header file. 
On my system the file is provided by the user kernel headers package and 
is /usr/include/linux/dvb/version.h.

If you have installed a new driver separate from the kernel then 
hopefully the driver will have provided new versions of the header 
files. You will need to persuade VDR to use these new files instead of 
the ones supplied with the kernel.


More information about the vdr mailing list