TODO RC: Difference between revisions

From LinuxTVWiki
Jump to navigation Jump to search
No edit summary
No edit summary
Line 21: Line 21:
** static u32 masks[] should be const
** static u32 masks[] should be const
** hverkuil: that array in rc_validate_filter is too short to handle post-RC_TYPE_SHARP types (TYPE_XMP, TYPE_CEC): it should have an ARRAY_SIZE check.
** hverkuil: that array in rc_validate_filter is too short to handle post-RC_TYPE_SHARP types (TYPE_XMP, TYPE_CEC): it should have an ARRAY_SIZE check.
* rc-main.c: put protocol variant keypress delay, name, scancode mask to common struct.


ir-keytable changes needed.
ir-keytable changes needed.

Revision as of 20:25, 7 August 2017

Investigation needed:

  • struct ir_raw_event_ctrl member prev_ev. Investigate if this can be removed.
  • serial_ir tx w/ softcarrier, does it work on 32 bit? "new_duty_cycle * NSEC_PER_SEC" > 2^32.
  • Kconfig RC_CORE should not depend on MEDIA_SUPPORT
  • if driver depends on RC_CORE, change this to select RC_CORE, depends on INPUT? OR use a patch like https://patchwork.linuxtv.org/patch/40601/ and remove "depends on RC_CORE".
  • RC device RC_DRIVER_IR_RAW_TX leaks dev->raw on rc_unregister_device()?
  • Unplug iguanair with lirc chardev open causes kernel to go bang
  • Compile kernel with KASAN. mceusb says:

[ 56.365080] BUG: KASAN: slab-out-of-bounds in mceusb_dev_printdata+0xdc/0x830 [mceusb] at addr ffff8801df071d0a

  • saa7134 should add trailing space (timeout handling). Once this is fixed, implement the following item.
  • ir_raw_event_store_edge() should not use REP_DELAY.

Worked needed:

  • ir-spi says "Unspecified device" in dmesg since ir-spi does not set input_name; rename input_name to device_name for all RC devices.
  • pwm gpio transmitter needed (Sean Young working on this)
  • bitbang gpio transmitter needed (Sean Young working on this)
  • lirc_zilog rc core driver (Sean Young working on this)
  • Once lirc_zilog is removed, remove lirc kapi.
  • Rename RC_TYPE_ to RC_PROTO_ and RC_BIT_ to RC_PROTO_BIT_
  • rc_validate_filter().
    • static u32 masks[] should be const
    • hverkuil: that array in rc_validate_filter is too short to handle post-RC_TYPE_SHARP types (TYPE_XMP, TYPE_CEC): it should have an ARRAY_SIZE check.
  • rc-main.c: put protocol variant keypress delay, name, scancode mask to common struct.

ir-keytable changes needed.