[linux-dvb] DVB on Debian: creating video devices, installing drivers...

Michael Krufky mkrufky at gmail.com
Tue Dec 6 19:47:37 CET 2005


On 12/6/05, a bell <a_n_d_y_bell at hotmail.co.uk> wrote:
>
> I'm tearing my hair out trying to get my new-model WinTV Nova-t card set
> up
> on latest
> Debian testing. After countless Google searches and much frustration,
> I'm posting here...
>
> Relevant info:
> 1. lspci turns up my PCI connexant chip ok.
> 2. DVB is compiled as a module in my 2.6.12 kernel; modprobe dvb_core,
> modprobe budget_core etc. run without complaint.
> 3. I don't have /dev/video0 etc. Running as root
> cd /dev; ./MAKEDEV video
> seems to have no effect - no errors produced, but no devices created
> either.
> 4. I have apt-get install'ed all the packages with dvb in the title, in
> particular dvb-utils.
> 5. Running scan [options] produces an error about not having /dev/video0
> 6. I tried downloading the latest cvs DVB thing from Linuxtv (but I
> half suspect this is only for pre-2.6.10 kernels, which don't have DVB
> drivers built in, no?). As stated in the INSTALL file, I have
> /lib/modules/$(KERNEL_VERSION)/build pointing to the kernel sources
> that I last built. But running make produces
> Makefile:102: /lib/modules/2.6.12/build/Rules.make: No such file or
> directory
>
> I'm confused.
>

There is a new cvs tree.... Try this:

http://linuxtv.org/v4lwiki/index.php/How_to_build_from_CVS

...you can probably skip the kernel recompile step.

Hope this helps,

Mike Krufky
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.linuxtv.org/pipermail/linux-dvb/attachments/20051206/6cea395e/attachment.htm


More information about the linux-dvb mailing list